
ВВЕДЕНИЕ

При разработке программ для мик�

роконтроллерных устройств разработ�

чик программы встречает ряд труднос�

тей, преодоление которых отнимает

время. Программист вынужден деталь�

но вникать в структуру программируе�

мого микроконтроллера, изучать на�

значение множества его регистров,

вплоть до каждого разряда, систему ко�

манд и т.п. Кроме того, существуют

непроизводительные затраты време�

ни, связанные с повторением этапов,

многократно пройденных другими

разработчиками.

Программисты при разработке

программы, как правило, создают ко�

ды, с помощью которых выполняют�

ся процедуры инициализации регис�

тров и векторов прерываний микро�

контроллера, формируют функции и

обработчики прерываний для внут�

ренних интерфейсов микроконтрол�

лера и внешних компонентов. Тем

самым разработчики программ фа�

ктически повторяют многие станда�

ртные процедуры. При этом большая

часть времени тратится на отладку

создаваемых функций и обработ�

чиков.

Если для реализации конкретного

алгоритма работы устройства действи�

тельно требуется уникальный код

программы, то для организации рабо�

ты с внутренними интерфейсами мик�

роконтроллера и стандартизованны�

ми внешними устройствами вполне

можно обходиться готовыми и прове�

ренными библиотеками, имеющими в

своём составе набор самых разнооб�

разных функций для конкретного ти�

па микроконтроллера.
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Современная среда разработки mikroC
для программирования микроконтроллеров
на языке высокого уровня Си
(часть 1)

Олег Вальпа (Челябинская обл.)

Приводится описание современной, мощной и удобной среды

разработки mikroC, которая включает большую библиотеку готовых

функций для работы с разнообразными интерфейсами и устройствами

и позволяет быстро создавать эффективные программы на языке

высокого уровня Си для микроконтроллеров семейств PIC, AVR,

MCS#51 и др.

Здесь можно провести аналогию с

популярной средой разработки про�

грамм для персональных компьюте�

ров Microsoft Visual С++, которая комп�

лектуется библиотекой готовых функ�

ций MFC. Такой комплект позволяет

создавать сложные программы в до�

вольно сжатые сроки, не тратя массу

времени на разработку функций для

работы с клавиатурой, манипулято�

ром «мышь», портами компьютера,

файлами графики, звуком и т.п. Ана�

логичные функции имеет среда раз�

работки Borland C++ Builder с библио�

текой VCL, а также другие мощные

инструменты для разработки компью�

терных программ для ПК.

Однако, в настоящее время не только

разработчики программ для ПК, но и

разработчики программ микроконт�

роллерных устройств могут восполь�

зоваться замечательной средой, име�

ющей в своём составе настоящий арсе�

нал готовых функций, позволяющих

использовать всю внутреннюю архи�

тектуру микроконтроллера с много�

численными типами интерфейсов и

множество стандартизованных внеш�

них устройств. Одним из таких про�

граммных инструментов является сре�

да разработки mikroC компании Mikro�

Elektronika [1].

НАЗНАЧЕНИЕ И СОСТАВ

СРЕДЫ РАЗРАБОТКИ

Данная среда разработки позволяет

быстро создавать эффективные про�

граммы на весьма распространённом

и популярном языке высокого уровня

Си. Среда имеет удобный и эрго�

номичный интерфейс пользователя

(IDE) со встроенным редактором

и мощным отладчиком программ.

Встроенный в среду разработки мас�

тер проектов позволяет в считанные

минуты создать заготовку рабочей

программы для любого микроконт�

роллера из целого семейства микро�

контроллеров. Библиотека готовых

функций, входящая в состав этой сре�

ды, обеспечивает программиста мощ�

ной поддержкой для быстрого и без�

ошибочного создания практически

любой программы.

Среда mikroC включает в себя огром�

ное количество библиотечных функ�

ций – практически на все случаи жиз�

ни. Она содержит функции, которые

поддерживают следующие устройства

и интерфейсы:

● встроенный аналого�цифровой пре�

образователь (АЦП) микроконтрол�

лера;

● внутреннюю энергонезависимую

память EEPROM микроконтроллера;

● внутренние широтно�импульсные

модуляторы (PWM) микроконтрол�

лера;

● внешние сменные карты памяти ти�

па MMC, SD и Compact Flash;

● файловую систему FAT;

● алфавитно�цифровые жидкокристал�

лические индикаторы (LCD, ЖКИ);

● графические жидкокристалличес�

кие индикаторы (GLCD, ЖК�дисп�

лей);

● интерфейсы I2C, SPI, 1�Wire, USART,

RS�485, CAN, PS/2, USB (HID) и Ether�

net.

Компания MikroElektronika создала

среду разработки mikroC для таких по�

пулярных и известных микроконтрол�

леров, как семейство PIC компании Mi�

crochip, AVR компании Atmel и MCS�51.

Ведётся разработка среды и для других

типов МК, в том числе, для самых со�

временных 32�разрядных ARM�конт�

роллеров.

Удачным подходом в создании дан�

ных сред является преемственность

интерфейса для пользователя, что поз�

воляет сэкономить время и силы на

изучение среды для нового семейства
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ПРОГРАММИРОВАНИЕ

микроконтроллеров и сразу же присту�

пать к этапу программирования.

ОБЗОР СРЕДЫ

Рассмотрим среду разработки mik�

roC для весьма популярных и распро�

странённых микроконтроллеров се�

мейства PIC компании MicroChip [2] на

примере версии 8.2.0.0. Другие версии

данной среды разработки аналогичны

описываемой здесь и отличаются несу�

щественно.

Поскольку компания MikroElektro�

nika использует принцип наследова�

ния для своих продуктов, переход к

среде разработки для других семейств

микроконтроллеров происходит до�

вольно просто. Интерфейс пользова�

теля и даже названия подавляющей

части библиотечных функций в среде

разработки mikroC для различных се�

мейств микроконтроллеров остаются

практически неизменными. Поэтому,

изучив и освоив на практике описыва�

емую здесь среду mikroC для микро�

контроллеров семейства PIC, в даль�

нейшем можно будет легко создавать

программы для микроконтроллеров

других семейств в соответствующей

для них среде mikroC.

Среда MikroC является дружествен�

ной и интуитивно понятной. На рисун�

ке 1 представлено главное окно среды

разработки. В центре этого окна распо�

лагается редактор кода (Code Editor) с

исходным текстом программы на язы�

ке программирования Си. Слева от ре�

дактора кода находится окно с заклад�

ками проводника кода (Code Explorer),

быстрой помощи (QHelp) и назначе�

нием клавиш (Keyboard).

Под окном редактора кода находит�

ся окно с закладками настройки про�

екта (Project Setup) и содержимого

проекта (Project Summary). Внизу рас�

полагается окно с закладками сообще�

ний (Messages), поиска (Find) и быст�

рого конвертора (QConvertor). Справа

находится панель инструментов, а

сверху – главное меню среды разра�

ботки.

Среда MikroC имеет следующие воз�

можности:

● текст программы вводится с по�

мощью встроенного редактора ис�

ходного кода;

● все строки программы имеют нуме�

рацию;

● имеется встроенная помощь кода и

параметров, контекстная подсветка,

автоматическая коррекция кода, ко�

довые шаблоны и т.п.;

● проводник кода (Code Explorer) поз�

воляет оперативно контролировать

структуру программы, переменные

и функции проекта;

● после компиляции проекта создаются

комментированный файл на ассем�

блере и стандартный HEX�файл для

использования разными типами

программаторов;

● встроенный отладчик позволяет

проверять ход и логику исполнения

программы;

● после компиляции предоставляется

полная статистика использования

памяти, ассемблерный листинг, де�

рево вызовов функций и т.п.;

● включено большое количество при�

меров, которые можно расширять и

использовать как составные части

разрабатываемых проектов.

СОЗДАНИЕ ПРОГРАММЫ

Программы в mikroC организованы

в виде проектов, состоящих из файла

проекта с расширением .ppc, одного

или нескольких файлов исходного ко�

да, имеющих расширение .c, а также

создаваемых в процессе трансляции

вспомогательных файлов. Файл с ис�

ходным кодом автоматически компи�

лируется, если он включен в состав

проекта.

Файл проекта несёт следующую ин�

формацию:

● имя проекта и необязательное опи�

сание;

● тип микроконтроллера;

● конфигурацию;

● тактовую частоту микроконтрол�

лера;

● список исходных файлов проекта с

указанием путей к ним.

Самый простой способ создания

проекта – использовать для этих це�

лей мастер новых проектов, который

запускается из главного меню с по�

мощью команды Project → New Project.

В открывшемся окне нового проекта

(см. рис. 2) следует заполнить поля

65WWW.SOEL.RUСОВРЕМЕННАЯ ЭЛЕКТРОНИКА ◆ № 6  2010
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описания проекта необходимыми зна�

чениями (название и описание про�

екта, расположение, устройство, час�

тота, слово конфигурации). После

щелчка по программной кнопке OK

mikroC создаст соответствующий файл

проекта.

Кроме этого, после создания проек�

та будет создан пустой исходный файл

с расширением .c для текста програм�

мы, имеющий название проекта. Среда

MikroC не требует, чтобы исходный

файл имел такое же название, как про�

ект, поэтому его можно переимено�

вать.

В любое время можно изменить

настройки проекта, используя глав�

ное меню Project → Edit Project. Про�

ект можно переименовать, изменить

его описание, используемый микро�

контроллер, частоту, конфигурацию

и т.п.

Для удаления проекта достаточно

удалить папку, в которой располагает�

ся файл проекта с расширением .ppc.

Проект может содержать произволь�

ное количество исходных файлов с

расширением .c. Список имеющих

отношение к проекту файлов сохраня�

ется в файле самого проекта. Чтобы до�

бавить исходный файл в проект, надо

выбрать команду Project → Add to Pro�

ject из выпадающего меню или клик�

нуть мышкой по пиктограмме добавле�

ния файла к проекту .

Для удаления файла из проекта сле�

дует выбрать команду Project → Remove

from Project из выпадающего меню

или кликнуть по пиктограмме удале�

ния файла из проекта .

Для включения в проект заголовоч�

ного файла с расширением .h, следует

использовать в коде программы дирек�

тиву препроцессора #include, напри�

мер:

#include <header_name>

или

#include "header_name"

Чтобы создать новый исходный

файл, следует выбрать команду File →
→ New из выпадающего меню, или на�

жать комбинацию клавиш Ctrl+N, или

кликнуть мышкой по пиктограмме соз�

дания нового файла . После этого

открывается вкладка с новым названи�

ем. Это и есть новый исходный файл.

Для задания названия следует выбрать

команду File → Save As из выпадающего

меню и сохранить файл с новым назва�

нием.

Чтобы отрыть уже существующий

файл, надо выбрать команду File →
→ Open из выпадающего меню, или на�

жать комбинацию клавиш Ctrl+O, или

кликнуть мышкой по иконке открытия

файла . После этого появляется окно

выбора файла, в котором и следует

произвести обычные действия по вы�

бору и открытию. Открытый файл вы�

водится в собственной вкладке. Если

выбранный файл уже открыт, его

вкладка становится активной, т.е. до�

ступной для редактирования.

Если потребуется распечатать какой�

либо файл проекта, то вкладка файла,

который предполагается вывести на

печать, должна быть активной. Затем

следует выбрать команду File → Print

из выпадающего меню, или нажать

клавиши Ctrl+P, или кликнуть мышкой

по пиктограмме печати. В предвари�

тельном окне печати следует устано�

вить необходимые настройки печати и

кликнуть по кнопке OK. После этого

файл будет отправлен на выбранный

принтер.

Для сохранения файла надо вы�

брать команду File → Save из выпадаю�

щего меню, или нажать клавиши

Ctrl+S, или кликнуть мышкой по пик�

тограмме сохранения файла. Файл

будет сохранён под старым названи�

ем. Вкладка файла, который предпо�

лагается сохранять, должна быть ак�

тивной.

Для сохранения файла под другим

названием следует выбрать File → Save

As из выпадающего меню или нажать

клавиши Ctrl+Shift+S. После этого вы�

водится диалоговое окно сохранения

файла под другим названием. В этом

окне надо выбрать каталог, где будет

сохранён файл. В поле имени файла

надо задать новое название и клик�

нуть мышкой по пиктограмме сохра�

нения.

Закрытие файла выполняется вы�

бором команды File → Close из выпа�

дающего меню или кликом по кнопке

закрытия вкладки. Если файл был из�

менён со времени последнего сохра�

нения, будет предложено сохранить

эти изменения.

РЕДАКТИРОВАНИЕ КОДА

ПРОГРАММЫ

Среда разработки программ mikroC

имеет встроенный современный текс�

товый редактор, способный удовлет�

ворить запросы даже искушённого

ПРОГРАММИРОВАНИЕ
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профессионала. Редактирование кода

программы практически не отличает�

ся от работы со стандартным тексто�

вым редактором, включая возможнос�

ти копирования, вставки и отката, ис�

пользуемые в операционной системе

Windows.

Но, кроме основных операций,

этот редактор поддерживает специ�

альные сервисные возможности, зна�

чительно облегчающие труд про�

граммиста. К этим возможностям от�

носятся:

● настраиваемая контекстная подсвет�

ка (Syntax Highlighting);

● кодовый ассистент (Code Assistant);

● ассистент параметров (Parameter As�

sistant);

● кодовые шаблоны;

● автокоррекция кода программы

(Auto Correct);

● закладки и переходы по номеру

строки.

Настройка параметров этих возмож�

ностей редактора осуществляется в ок�

не диалога Preferences (см. рис. 3). Дан�

ный диалог запускается с помощью

команды Tools → Options из выпадаю�

щего меню или щелчком мыши по

пиктограмме .

Рассмотрим подробнее назначение

и использование этих возможностей.

Контекстная подсветка значительно

улучшает читаемость программы и

обнаружение в ней ошибок за счёт ав�

томатического окрашивания фраг�

ментов программы в соответствии

с их функциональным назначени�

ем. Например, как это сделано в окне

с кодом программы диалога Prefe�

rences.

Диалог Preferences редактора кода

программы уже содержит три готовые

схемы раскраски с названиями: mikro�

Dream (с белым фоном), MrGreen (с зе�

лёным фоном) и Zedar (с чёрным фо�

ном). В диалоге Preferences пользова�

тель среды может выбрать любую из

имеющихся схем подсветки либо соз�

дать свою собственную.

Кодовый ассистент (Code Assistant)

подсказывает правильное название и

написание существующего кода про�

граммы. Например, если в редакторе

кода программы напечатать один или

несколько символов слова и нажать

клавиши Ctrl+Space, все разрешённые

идентификаторы, соответствующие

напечатанным символам, будут пред�

ложены во всплывающем окне (см.

рис. 4). Теперь можно продолжить ввод

символов для сужения предлагаемого

списка или с помощью стрелок на кла�

виатуре выбрать подходящий вариант

кода из предложенных строк и нажать

клавишу Enter.

Ассистент параметров (Parameter As�

sistant) помогает правильно ввести па�

раметр или аргумент функции. Он вы�

зывается автоматически после ввода

символа открывающейся скобки «(»

или после нажатия комбинации кла�

виш Shift+Ctrl+Space. Если имя разре�

шённой функции предшествует скоб�

кам, предполагаемые аргументы будут

выведены на всплывающую панель. По

мере печати очередного фактического

аргумента, следующий предлагаемый

аргумент будет выделен жирным

шрифтом.

Кодовые шаблоны помогают уско�

рить ввод стандартных операторов и

конструкций языка программирова�

ния без ошибок. Шаблон можно встав�

лять в текст программы, вводя назва�

ние шаблона (например, for) и нажав

комбинацию клавиш Ctrl+J, после чего

редактор автоматически сгенерирует

код шаблона и вставит его в текст про�

граммы. Другой способ вставки шаб�

лона заключается в вызове диалога с

помощью клавиши F12 и последую�

щем выборе шаблона из списка в за�

кладке Auto Complete, с переносом его

в код программы копированием.

Кроме того, можно добавить соб�

ственные шаблоны с помощью диа�

лога Preferences на вкладке Auto 

Complete. Для этого следует ввести со�

ответствующее ключевое слово, опи�

сание и свой кодовый шаблон. Авто�

коррекция позволяет исправлять наи�

более часто встречающиеся опечатки.

Для доступа к списку распознаваемых

опечаток следует выбрать команду

Tools → Options из выпадающего ме�

ню или кликнуть по пиктограмме

инструментов , а затем выбрать

вкладку Auto Correct. Здесь можно до�

бавить в список свои собственные

предпочтения.

Закладки облегчают навигацию в ко�

де большого размера. Для установки

закладки используется комбинация

клавиш Ctrl+Shift+number. Для перехо�

да к закладке используется Ctrl+num�

ber.

Переход на заданную строку облег�

чает навигацию в коде большого раз�

мера. Для этого достаточно нажать

комбинацию клавиш Ctrl+G и в по�

явившемся окне (см. рис. 5) ввести но�

мер искомой строки.

Кроме этого, редактор исходного ко�

да имеет возможность показывать и

скрывать комментарии к выбранному

коду одним кликом мышки, используя

пиктограммы Comment Code и Re�
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Рис. 3. Окно диалога Preferences

Рис. 4. Окно Code Assistant



move Comments на панели инстру�

ментов (Code Toolbar).

С появлением новых версий среды

разработки появляются и новые воз�

можности редактора кода. Их описа�

ние всегда можно найти во встроен�

ной справочной системе среды разра�

ботки.

КОМПИЛЯЦИЯ ПРОЕКТА

После создания проекта и написа�

ния исходного кода необходимо вы�

полнить его компиляцию. Для этого

следует выбрать команду Run → Com�

pile из выпадающего меню или клик�

нуть по пиктограмме компилятора ,

расположенную на панели компиля�

тора (Compiler Toolbar).

Появившийся индикатор процесса

компиляции будет информировать о

ходе компиляции. В случае обнаруже�

ния ошибок появятся соответствую�

щие сообщения в окне ошибок (Error

Window). Если ошибок нет, в окне

Messages появятся сообщения об

успешной компиляции и объёме ис�

пользованной памяти микроконтрол�

лера под программу. В случае успеш�

ной компиляции среда mikroC созда�

ёт выходные файлы в каталоге про�

екта (каталог, где содержится файл

проекта с расширением .ppc). Описа�

ние выходных файлов приведено в

таблице 1.

После компиляции программы в

mikroC, можно кликнуть по иконке

просмотра ассемблера (View Assembly)

или выбрать команду View → View

Assembly из выпадающего меню, чтобы

проверить сгенерированный ассемб�

лерный код (файл с расширением

.asm) в новом окне. Ассемблерный код

представляет собой текст с символи�

ческими именами. Все физические ад�

реса и прочая информация может

быть найдена в статистике или файле

листинга.

Если программа не компилирова�

лась и ассемблерный файл не созда�

вался, использование этой возможнос�

ти приводит к компиляции кода и по�

лучению ассемблерного файла для

просмотра.

СТАТИСТИКА

После успешной компиляции можно

посмотреть статистические сведения

о коде. Для этого следует выполнить

команду View → View Statistics из вы�

падающего меню или кликнуть по пик�

тограмме статистики . При этом по�

явится окно с шестью вкладками (см.

рис. 6):

● окно использования памяти (Me�

mory usage) обеспечивает просмотр

использования RAM и ROM в форме

гистограмм;

● окно размера функций (Procedures

sizes) выдаёт в форме гистограммы

размеры памяти, занимаемой каж�

дой функцией;

● окно расположения функций (Pro�

cedures locations) выдаёт в форме

гистограммы положение в памяти,

занимаемой каждой функцией;

● окно детальной информации по

каждой функции (Procedures Details)

позволяет посмотреть полное дерево

вызова вместе с остальной инфор�

мацией: размер, начальный и конеч�

ный адреса, частота обращений, тип

возвращаемого значения и т.п.;

● окно RAM позволяет посмотреть

распределение всех регистров и их

адреса. Также выводятся символьные

имена переменных с адресами;

● окно ROM выдаёт список всех кодов

инструкций с адресами в читабель�

ном шестнадцатеричном представ�

лении.

ОТЛАДКА ПРОГРАММЫ

Отладчик в исходных кодах является

встроенной компонентой среды mik�

roC. Он предназначен для симуляции

работы МК и для облегчения пользова�

телю процесса отладки кодов програм�

мы на языке программирования Си,

написанных для этих микроконтрол�

леров.

После успешной компиляции про�

екта можно запустить отладчик с по�

мощью команды Run → Start debugger

из выпадающего меню, или кликнуть

по пиктограмме отладчика , или

нажать клавишу F9. При этом появит�

ся окно отладчика программы (см.

рис. 7).

Отладчик позволяет выполнять по�

шаговое исполнение программы (Step

Into), пошаговое исполнение с «пере�

шагиванием» функций (Step Over), ис�

полнение до текущей позиции курсора

(Run to Cursor) и т.д. Строка програм�

мы, которая будет исполняться, подсве�

чивается (по умолчанию – синим цве�

том).

В отладчике можно включать и вы�

ключать точки останова в текущей по�

зиции курсора с помощью клавиши

F5. Чтобы посмотреть все точки оста�

нова, используется команда Run→
→ View Breakpoints из выпадающего

меню. Щелчок левой кнопкой мыши

по номеру строки в окне исходного

текста программы также включает и

выключает точку останова в этой

строке.

Команда Run to cursor (клавиша F4)

выполняет все операторы программы

от текущего и до позиции курсора.

Команда Step Into (клавиша F7) вы�

полняет текущий оператор програм�

мы с заходом в вызываемую функцию.

Команда Step Over (клавиша F8) вы�

полняет текущий оператор програм�

мы без захода в вызываемую функцию.

Команда Step Out (клавиши Ctrl+F8)

последовательно выполняет все опе�

раторы программы, пока не встретит�

ся точка останова.

Переключение между окном про�

граммы на языке Си и окном с дизас�

семблированным кодом осуществля�

ется с помощью комбинации клавиш

Alt+D.

Окно наблюдения отладчика (Watch) –

это основное окно отладки, которое

позволяет контролировать элементы

программы во время её отладки. Что�

бы открыть окно наблюдения, надо вы�

брать команду View → Debug Windows →
→ View Watch из выпадающего меню

во время отладки. Окно наблюдения

показывает переменные и регистры

микроконтроллера, их адреса и значе�

ПРОГРАММИРОВАНИЕ
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Таблица 1. Описание выходных файлов

Формат файла Описание содержимого файла Расширение файла

Intel HEX
Шестнадцатеричный код в формате Intel.

Используется для программирования
hex

Двоичный
Библиотека компилятора mikroC. Двоичные дистрибутивы подпрограмм,

пригодные для включения в другие проекты
mcl

Файл листинга
Общая картина распределения памяти микроконтроллера:

адреса инструкций, регистры, программы и метки
lst

Текст на ассемблере
Читаемый ассемблерный файл с символическими именами,

полученный из файла листинга
asm

Рис. 5. Окно поиска строки по номеру



ПРОГРАММИРОВАНИЕ

ния. Значения обновляются в процес�

се симуляции работы программы в от�

ладчике. Последние изменённые эле�

менты в окне выделяются красным

цветом. Для добавления или удаления

наблюдаемых элементов в окно следу�

ет использовать соответствующее вы�

падающее меню.

Двойной щелчок на элементе в окне

наблюдения открывает окно редакти�

рования, где можно присвоить вы�

бранной переменной или регистру

новое значение. Также можно выбрать

двоичное, шестнадцатеричное, деся�

тичное или символьное представ�

ление этого значения в окне наблю�

дения.

Окно хронометража (Stopwatch) от�

ладчика (см. рис. 8) доступно из выпада�

ющего меню View → Debug Windows →
→ View Clock. В окне хронометража

отображается текущий счётчик (Cur�

rent Count) периодов тактовой частоты

и секунд от момента запуска отладчи�

ка. Секундомер (Stopwatch) измеряет

время исполнения в периодах такто�

вой частоты и секундах от момента за�

пуска отладчика и может быть обну�

лён в любое время. Разность (Delta)

представляет фактически время вы�

полнения участка программы от пре�

дыдущей точки останова до текущей в

периодах и секундах (при пошаговом

исполнении отображается время вы�

полнения одной строки кода програм�

мы на Си). Также в окне отображается

текущая тактовая частота микроконт�

роллера (Clock).

Тактовую частоту в окне хрономет�

ража можно изменять, что приведёт к

пересчёту времени в секундах. Это из�

менение не влияет на текущие уста�

новки проекта, где тоже задана так�

товая частота микроконтроллера, а

влияет только на расчёт времени си�

муляции.

Окно просмотра памяти (View RAM

Window) доступно из выпадающего ме�

ню View → Debug Windows → View RAM.

Окно просмотра памяти (см. рис. 9) по�

казывает карту памяти МК, где самые

последние изменения выделены крас�

ным цветом. Можно изменять значе�

ния полей карты памяти путём двой�

ного щелчка на нужном поле.

В случае если компилятор обнару�

живает ошибку, он сообщает об этом и

не создаёт выходной файл. Окно оши�

бок, расположенное по умолчанию

внизу основного окна, напоминает об

этом. Окно ошибок расположено под

вкладкой сообщений и отображает

место и тип ошибки, обнаруженной

компилятором. Также компилятор вы�

водит предупреждения, но они не вли�

яют на выходной файл. Двойной щел�

чок по строке сообщения в окне оши�

бок приводит к подсветке строки ис�

ходного текста, где эта ошибка была

обнаружена.

ИНСТРУМЕНТЫ СРЕДЫ

Встроенная карта ASCII (см. рис. 10)

позволяет посмотреть код любого сим�

вола ASCII в десятичном, шестнадцате�

ричном и двоичном формате. Открыть

карту символов ASCII можно из выпа�

дающего меню Tools → ASCII chart, а

посмотреть код символа очень удобно

с помощью мыши, наводя её курсор на

интересующий код в окне карты сим�

волов.

С помощью инструмента экспорта

кода, вызываемого из меню Tools → Ex�

port Code To HTML, можно очень прос�

то получить код программы в формате

HTML для публикации его в Интернете.

Например, код программы, получен�

ный из примера программы, описан�

ного выше, будет иметь следующий

вид на странице Интернет:

Version:0.9 StartHTML:0000000105

EndHTML:0000004659 StartFrag�

ment:0000001167 EndFrag�

ment:0000004643

void main() {

ADCON1 = 0x80; // Configure ana�

log inputs and Vref
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Рис. 6. Окно статистики Рис. 7. Окно отладчика программы

Рис. 8. Окно хронометража отладчика Рис. 9. Окно просмотра памяти МК



TRISA = 0xFF; // PORTA is input

TRISB = 0x3F; // Pins RB7, RB6

are outputs

TRISD = 0; // PORTD is output

do {

temp_res = Adc_Read(2); // Get

results of AD conversion

PORTD = temp_res; // Send lower 8

bits to PORTD

PORTB = temp_res >> 2; // Send 2

most significant bits to RB7, RB6

} while(1);

В среду mikroC включен терминал

связи USART для работы с интерфей�

сом RS�232 (см. рис. 11). Его можно

запустить из выпадающего меню

Tools → Terminal, или щелчком по

иконке терминала, или с помощью

клавиш Ctrl+T. Он позволяет отлажи�

вать программы, в которых исполь�

зуется интерфейс USART для связи с

внешними устройствами, на разных

скоростях и с различными формата�

ми данных.

Декодер семисегментных символов

(см. рис. 12) является удобным инстру�

ментом получения кодов индикации

по нужной комбинации активных сег�

ментов. Активация и деактивация сег�

мента осуществляется простым щелч�

ком мыши на изображении сегмента.

Декодер можно запустить из выпада�

ющего меню Tools → Seven Segment De�

coder.

Встроенный генератор кода для ЖК�

индикаторов (см. рис. 13) позволяет

очень легко создать любой символ для

матрицы ЖКИ. Данный генератор кода

запускается из выпадающего меню

Tools → LCD Custom Character. Он же

позволяет сгенерировать программ�

ный код для отображения этого сим�

вола на языке программирования

mikroPascal, mikroBasic или mikroC (см.

рис. 14) простым нажатием на программ�

ную кнопку GENERATE. Ниже приведён

программный код на языке програм�

мирования Си, полученный данным

генератором кода.

const char character[] =

{0,0,16,0,2,0,8,0};

void CustomChar(char pos_row,

char pos_char) {

char i;

LCD_Cmd(64);

for (i = 0; i<=7; i++)

LCD_Chr_Cp(character[i]);

LCD_Cmd(LCD_RETURN_HOME);

LCD_Chr(pos_row, pos_char, 0);

}

Ещё более мощным встроенным

инструментом среды является генера�

тор кода для графических ЖК�диспле�

ев (см. рис. 15). Он запускается из вы�

падающего меню Tools → GLCD Bitmap

Editor и позволяет создавать точечные

рисунки для дисплеев типа KS0108,

ПРОГРАММИРОВАНИЕ
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Рис. 10. Встроенная карта ASCII

Рис. 11. Терминал связи USART
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T6963 и Nokia3110, а также генериро�

вать программный код для этих дис�

плеев на трёх языках программиро�

вания.

Для отладки программ, обеспечива�

ющих работу с картами памяти типа

MMC, существует встроенный инстру�

мент MMC Terminal (см. рис. 16). Он

запускается из выпадающего меню

Tools → MMC Card Terminal и позволя�

ет осуществлять чтение и запись дан�

ных карты памяти по секторам через

последовательный COM�порт компь�

ютера. Встроенный редактор пере�

программируемой памяти микроконт�

роллера (см. рис. 17) запускается из

выпадающего меню Tools → EEPROM

Editor и позволяет модифицировать

данные этой памяти.

Для отладки программ можно ис�

пользовать специальный загрузчик

программ mikroBootloader (см. рис. 18).

Поскольку многие семейства МК име�

ют возможность записывать в свою

собственную программную память

данные, это позволяет хранить в них

небольшую программу�загрузчик, ко�

торая будет принимать и записывать в

программную память коды програм�

мы. В наиболее простом варианте за�

грузчик передаёт управление програм�

ме пользователя всегда, кроме случая,

когда есть запрос на загрузку новой

программы. В такой ситуации загруз�

чик получает данные и записывает их

в программную память. Существует

много усовершенствований, которые

могут быть добавлены, чтобы сделать

процесс загрузки более надёжным и

удобным.

Естественно, что загрузчик можно

использовать только с микроконт�

роллерами, поддерживающими за�

пись во флэш�память программ. Ре�

зидентная часть загрузчика даёт

компьютеру 5 с на то, чтобы устано�

вить с ней связь. Если этого не проис�

ходит, она запускает на исполнение

имеющуюся программу пользовате�

ля. Если связь установлена, резидент�

ная часть загрузчика принимает коды

и записывает их в программную па�

мять.

Ниже описан процесс использова�

ния загрузчика:

● загрузить в микроконтроллер необ�

ходимый файл программы, исполь�

зуя обычную технологию програм�

мирования файла в HEX�формате.

Например, для микроконтролле�

ра PIC16F877A использовать файл

p16f877a.hex;
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Рис. 12. Декодер семисегментных символов

Рис. 13. Встроенный генератор кода для ЖК+

индикаторов

Рис. 14. Окно с примером кода для ЖК+индикаторов

Рис. 15. Генератор кода для графических ЖК+дисплеев

Рис. 16. Встроенный инструмент MMC Terminal



● запустить загрузчик из выпадаю�

щего меню Tools → mikroBootloa�

der;

● щёлкнуть на Setup Port и затем вы�

брать номер COM�порта, используе�

мого для связи с микроконтролле�

ром. Убедиться, что установлена ско�

рость обмена 9600 кБод;

● выбрать из меню Open File и за�

тем выбрать файл с кодами для за�

грузки;

● поскольку резидентный загрузчик

микроконтроллера даёт компьюте�

ру не более 5 с на установку соедине�

ния, следует сбросить микроконт�

роллер, а затем в течение не более

5 с жать на кнопку Connect;

● теперь последняя строчка в окне

истории будет Connected;

● для запуска загрузки щёлкнуть по

программной кнопке Start Bootloa�

der;

● программа будет загружаться в па�

мять микроконтроллера. Загрузчик

будет сообщать об ошибках, возни�

кающих в процессе загрузки;

● сбросить микроконтроллер и на�

чать исполнение загруженной про�

граммы.

Наиболее общие функции загрузчи�

ка перечислены ниже:

● адрес аппаратного сброса находится

в распоряжении резидентной про�

граммы загрузки;

● другая часть кода резидентного за�

грузчика занимает небольшую про�

извольную область памяти;

● проверяется необходимость начала

загрузки нового кода;

● если нет необходимости загрузки

нового кода, то запускается на ис�

полнение имеющийся в памяти код

пользователя;

● при загрузке новые данные прини�

маются по каналу связи;

● принятые данные записываются в

программную память.

Взаимодействие кода пользователя

и резидентного загрузчика имеет неко�

торые особенности. Резидентная часть

практически всегда использует адрес

рестарта и некоторую дополнитель�

ную область памяти. Это – небольшой

фрагмент кода, который не использует

прерываний, таким образом, пользова�

телю становится доступен вектор пре�

рываний по адресу 0x0004. Резидент

загрузчика должен избегать использо�

вания вектора прерывания, поэтому

переход к остальной части програм�

мы загрузки должен производиться в

пределах адресов от 0x0000 до 0x0003.

ПРОГРАММИРОВАНИЕ
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Рис. 17. Встроенный редактор перепрограммируемой памяти МК

Рис. 18. Загрузчик программ mikroBootloader

Рис. 19. Встроенный инструмент отладки программ для USB+устройств



ПРОГРАММИРОВАНИЕ

Резидентный загрузчик должен про�

граммироваться в микроконтроллер с

использованием обычного програм�

матора, одновременно с битами кон�

фигурации. Резидентный загрузчик не

позволяет менять биты конфигурации,

поскольку они располагаются за пре�

делами программной памяти.

Для отладки программ для USB�

устройств существует встроенный

инструмент (см. рис. 19), запускаемый

из выпадающего меню Tools → HID Ter�

minal.

При создании программ для сетевых

устройств с интерфейсом Ethernet

очень полезным может оказаться

встроенный инструмент UDP Terminal

(см. рис. 20). Он запускается из выпада�

ющего меню Tools → UDP Terminal и

позволяет отлаживать программы,

поддерживающие сетевой протокол

UDP.

Созданную и отлаженную програм�

му можно записать в память про�

грамм микроконтроллера непосред�

ственно из среды разработки с

помощью специального программа�

тора, разработанного в компании

MikroElektronika.

Программирование (см. рис. 21) за�

пускается из выпадающего меню

Tools → mE Programmer или с по�

мощью клавиши F11. После програм�

мирования МК можно приступать к

тестированию программы в реаль�

ном устройстве.

КЛАВИАТУРНЫЕ КОМАНДЫ

В таблице 2 приводится список кла�

виатурных команд, используемых в

mikroC. Данный список команд с опи�

санием назначения на английском

языке можно посмотреть в окне про�

водника кода (Code Explorer), на вклад�

ке Keyboard.

Продолжение следует

ЛИТЕРАТУРА

1. www. mikroe.com.

2. www.microchip.com.
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Рис. 20. Встроенный инструмент UDP Terminal Рис. 21. Окно запуска программирования

Таблица 2. Список клавиатурных команд

Клавиши Команды среды разработки
F1 Помощь

Ctrl+N Новый файл

Ctrl+O Открыть файл

Ctrl+F9 Компилировать проект

Ctrl+F11 Включение/выключение проводника кода

Ctrl+Shift+F5 Просмотр точек останова

Основные команды редактирования
F3 Найти, найти далее

Ctrl+A Выделить всё

Ctrl+C Копировать

Ctrl+F Найти

Ctrl+H Заменить

Ctrl+P Печатать

Ctrl+S Сохранить

Ctrl+Shift+S Сохранить как

Ctrl+V Вставить

Ctrl+X Вырезать

Ctrl+Y Повтор отменённого действия

Ctrl+Z Отменить действие

Расширенные команды редактирования
Ctrl+Space Помощь в коде (Code Assistant)

Ctrl+Shift+Space Помощь в параметрах (Parameters Assistant)

Ctrl+D Найти определение

Ctrl+G Перейти к строке номер

Ctrl+J Вставить шаблон кода

Ctrl+number Перейти к закладке

Ctrl+Shift+number Установить закладку

Ctrl+Shift+I Отступ для выделенной части текста

Ctrl+Shift+U Отмена отступа для выделения части текста

Alt+Select Выбрать столбец

Команды отладчика
F4 Выполнить всё до курсора

F5 Включение/выключение точки останова

F6 Пуск/пауза программы в отладчике

F7 Шаг с заходом в функцию

F8 Шаг без захода в функцию

Ctrl+F8 Шаг с выходом из функции

F9 Запуск отладчика

Ctrl+F2 Сброс


