
РАБОТА С ПРОЕКТАМИ

В LPCXPRESSO IDE
После завершения загрузки ПО

GNU toolchain пользователь может пе�

рейти непосредственно к работе в

LPCXpresso IDE, т.е. к созданию собст�

венных проектов.

Каждой рабочей области в LPCXpres�

so IDE сопоставляется отдельный ка�
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талог на диске ПК. При этом ресурсы

всех создаваемых пользователем в

LPCXpresso IDE проектов по умолча�

нию будут храниться в каталоге той ра�

бочей области, в которой они создава�

лись. Указанный каталог может созда�

ваться LPCXpresso IDE, например, в

папке Documents and Settings\User\My

Documents\lpcxpresso_3.6\workspace.

Сохранение ресурсов в каталоге их ра�

бочей области автоматически произ�

водится при выходе из LPCXpresso IDE.

При необходимости задания катало�

га рабочей области на диске ПК следу�

ет до начала создания проектов вы�

брать в меню перспективы File > Switch

Workspace > (Other…) >, после чего от�

кроется диалоговое окно Workspace

Launcher, как показано на рисунке 4. В

этом окне следует указать название ка�

талога рабочей области и путь к нему.

При каждом запуске LPCXpresso IDE

окно Workspace Launcher будет авто�

матически открываться, предостав�

ляя возможность выбора той рабочей

области, которая будет загружена в

LPCXpresso IDE.

Первое, что рекомендуется сделать

в начале разработки приложения

LPCXpresso IDE, – создать новый про�

ект (project). Под проектом здесь по�

нимается группа связанных между со�

бой исходных и заголовочных файлов

(для проекта на языке C – файлов с рас�

ширениями *.c и *.h), содержащих ис�

ходный текст встроенной управляю�

щей программы для целевого МК.

Под приложением (application) в

широком смысле здесь понимается со�

вокупность всех файлов проекта,

включая служебные и исполняемые

файлы, генерируемые в ходе работы

с проектом в LPCXpresso IDE. В более

узком смысле приложение – это ре�

зультат компиляции и компоновки

проекта, представляющий собой

встроенную управляющую программу.

Среда LPCXpresso IDE обеспечивает

возможность создания проектов не�

скольких типов. Для создания проекта

в меню перспективы следует выбрать

File > New > Project..., после чего откро�

ется диалоговое окно выбора типа но�

вого проекта New Project, показанное

на рисунке 5.

Допустим, мы создаём проект с ис�

ходным текстом на языке C, для по�

строения которого предполагается ис�

Использование инструментария LPCXpresso
для разработки приложений на базе
32�разрядных микроконтроллеров NXP
с ядрами ARM Cortex�M0 и Cortex�M3
Часть 2

Павел Редькин (г. Ульяновск)

Статья посвящена программно�аппаратному обеспечению LPCXpresso,

предназначенному для разработки и отладки приложений

для 32�разрядных микроконтроллеров семейств LPC11xx/13xx/17xx

производства NXP с ядрами ARM Cortex�M0, Cortex�M3.

Рис. 5. Диалоговое окно выбора типа нового проекта New Project

Рис. 4. Диалоговое окно выбора рабочей области Workspace Launcher
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пользовать любой из доступных в

LPCXpresso IDE наборов инструментов.

Выбираем в этом окне позицию папки

C/C++, а в ней – позицию табуляции

C Project, как показано на рисунке 5, и

кликаем на кнопке Next. При этом от�

крывается диалоговое окно задания

типа, названия и местоположения но�

вого проекта, а также выбора инстру�

ментария для его построения (Tool�

chains), показанное на рисунке 6. В

этом окне необходимо задать назва�

ние проекта (например, Pro_1) в соот�

ветствующем поле, а также указать мес�

торасположение ресурсов проекта на

диске ПК (Location) в случае, если

предполагается их размещение не по

умолчанию (отключена настройка Use

default location). При включенной на�

стройке Use default location ресурсы

проекта будут размещаться внутри ка�

талога рабочей области.

При создании проекта пользователь

может выбрать один из следующих

типов.

Executable – исполняемое приложе�

ние, папка этого типа проекта содер�

жит следующие шаблоны проектов:

● Empty Project – проект, который не

содержит никаких исходных фай�

лов. Если выбрать этот шаблон, то бу�

дет создан проект, включающий

только служебные файлы мета�дан�

ных, которые содержат параметры

настройки проекта. Предполагается,

что пользователь сам создаст исход�

ные файлы и добавит их в проект.

Для дальнейшего построения этого

проекта, в поле Toolchains предлага�

ется выбрать из списка доступных

наборов инструментов (в нашем слу�

чае Code Red MCU Tools и MinGW GCC);

● LPCXpresso Empty C Project – проект,

аналогичный предыдущему, однако

для его построения доступен только

инструментарий Code Red MCU Tools;

● Hello World ANSI C Project – простое

приложение на языке C с названием

Hello World, имеющее в своём составе

главную функцию main(). Для его

построения доступен только инстру�

ментарий MinGW GCC.

Shared Library – исполняемый мо�

дуль, который компилируется и ком�

понуется отдельно. Когда создаётся

проект, использующий shared library

(libxx.so), CDT комбинирует объектные

файлы таким образом, чтобы они бы�

ли перемещаемыми и могли быть раз�

делены многими процессами. Make�

файл (makefile) проекта для этого типа

генерируется автоматически. Заметим,

что make�файл любого проекта содер�

жит набор скриптов, в которых ука�

заны взаимозависимости файлов дан�

ного проекта и правила для их пре�

образования. На основе информации,

содержащейся в make�файле, входя�

щая в LPCXpresso IDE утилита make

определяет и запускает на выполнение

необходимые инструментальные про�

граммы (компилятор, компоновщик

и пр.).

Static Library – коллекция объектных

файлов, которые можно скомпоновать

в составе другого приложения (libxx.a).

CDT объединяет объектные файлы (*.o)

в архив (*.a), который непосредственно

компонуется в составе исполняемого

приложения. Make�файл проекта для

этого типа генерируется автомати�

чески.

Makefile Project – пустой проект без

файлов мета�данных. Выбор это�
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Рис. 6. Диалоговое окно задания основных параметров нового проекта на C
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го типа проекта может использо�

ваться, чтобы импортировать и из�

менять существующие makefile�про�

екты. Make�файл проекта для этого

типа автоматически не генериру�

ется.

Задав тип, название, местоположе�

ние и инструментарий проекта, щёлка�

ем на кнопке Next, после чего открыва�

ется диалоговое окно выбора конфи�

гурации компоновки проекта Select

Configurations. В этом окне по умолча�

нию предлагается создать проект в

двух конфигурациях компоновки: De�

bug и Release (отладка и выгрузка). Не

изменяя заданные по умолчанию на�

стройки, щёлкаем на кнопке Next, по�

сле чего открывается диалоговое окно

выбора МК целевой системы проекта

Select processor type, как показано на ри�

сунке 7. В этом окне красным цветом

указаны те МК, размер флэш�памяти

которых превышает максимальный

размер кода, генерируемого LPCXpres�

so IDE (в нашем случае 128 Кб). Выбрав

МК целевой системы, щёлкаем на

кнопке Finish, после чего позиция табу�

ляции папки проекта появляется в ок�

не проводника проектов Project Ex�

plorer, как показано на рисунке 8. Эта

позиция может быть развёрнута.

При необходимости иметь в составе

проекта создаваемый по умолчанию

код запуска выбранного МК выбираем

в окне выбора типа нового проекта

New Project (см. рис. 5) позицию папки

LPCXpresso C Project и щёлкаем на кноп�

ке Next. Открывается диалоговое окно

New LPCXpresso C Project (см. рис. 9), в

котором можно выбрать семейство МК

целевой системы. Для примера выби�

раем позицию NXP LPC1700 C Project и

щёлкаем на кнопке Next, после чего

откроется диалоговое окно задания

названия нового проекта и пути к нему

(New Project). Задав название (напри�

мер, Pro_Led_led) и местоположение

каталога размещения нового проекта,

щёлкаем на кнопке Next, после чего

открывается диалоговое окно выбора

МК, аналогичное показанному на ри�

сунке 7. Выбрав нужный МК, например

LPC1768, щёлкаем на кнопке Next, по�

сле чего откроется диалоговое окно за�

дания параметров создаваемого про�

екта, показанное на рисунке 10.

Параметр этого окна Use CMSIS pe�

ripheral header files and initialization

code задаёт использование в качестве

т.н. опорной информации (reference)

нашего проекта заголовочных файлов

и кода инициализации периферии из

стандарта программного интерфейса

МК Cortex CMSIS. Этот стандарт пред�

ставляет собой набор файлов (моду�

лей) с исходными и заголовочными

текстами, описывающими встроенную

периферию МК с ядром Cortex (регист�

ры специальных функций), а также

векторы исключений. Необходимо от�

ПРОГРАММИРОВАНИЕ
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Рис. 7. Диалоговое окно выбора МК целевой системы проекта Select processor type

Рис. 8. Главное окно перспективы LPCXpresso IDE с проектами, отображаемыми в окне проводника

проектов Project Explorer
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метить, что для использования этой

возможности в создаваемом проекте в

нашу рабочую область должен быть

предварительно импортирован биб�

лиотечный проект CMSIS из подката�

лога Examples, созданного по умолча�

нию при инсталляции LPCXpresso IDE.

Порядок импорта будет описан ниже.

Параметр Enable CRP in the target

image задаёт включение защиты кода

в памяти МК от чтения.

Название подкаталога в каталоге

проекта, содержащего исходные фай�

лы пользователя, может быть задано в

поле User source directory. По умолча�

нию подкаталог называется src.

Задав параметры проекта, щёлкаем

на кнопке Finish, после чего позиция

табуляции папки проекта появляется в

окне обозрения проводника проектов

Project Explorer (см. рис. 8). Эта позиция

может быть развёрнута. Созданный на�

ми проект по умолчанию содержит

файл кода запуска для выбранного МК

cr_startup_lpc176x.c, а также файл ис�

ходного текста основной функции

main.c с практически пустым главным

циклом управляющей программы.

Двойным щелчком мыши на позиции

табуляции файла main.c можно отрыть

его для просмотра и редактирования в

окне редактора. Фактически этот файл

представляет собой заготовку, в кото�

рую разработчик может вставить

собственный исходный текст. При

этом в файле main.c уже имеются кор�

ректные директивы подключения не�

обходимых заголовочных и исходных

файлов, связанных с выбранной аппа�

ратной платформой и опорной ин�

формацией. После создания проекта

можно вручную сохранить его на

диске ПК, выбрав в меню перспекти�

вы File > Save, или комбинацией кла�

виш CTRL+S.

Следует отметить, что создание

(импорт) проекта, а также другие свя�

занные с ним операции (формирова�

ние, отладка и пр.), которые будут рас�

смотрены ниже, удобно производить

с помощью открытого по умолчанию

раздела Start here окна обозрения

Quickstart Panel (см. рис. 8). При необ�

ходимости можно отрыть это окно,

выбрав в меню перспективы Window >

> Show View > (Other...) > Quickstart >

> Quickstart Panel. В разделах этого окна

содержатся и другие полезные коман�

ды, например, команда создания ново�

го исходного файла на языке C в соста�

ве текущего проекта Create New C source

file (раздел Project and File wizards),

группа команд Additional resources (раз�

дел Extras), позволяющих получить

быстрый доступ к интернет�ресурсам

пакета программ LPCXpresso.

Помимо создания проектов на базе

различных шаблонов, LPCXpresso IDE

предоставляет разработчику возмож�

ность импортировать в рабочую об�

ласть уже готовые проекты, в частнос�

ти, содержащиеся в самом пакете

LPCXpresso IDE. Рассмотрим импорт в

рабочую область библиотечного про�

екта CMSIS из подкаталога Examples,

чтобы в рабочей области можно было

создавать новые исполняемые проек�

ты, поддерживающие CMSIS.

В окне обозрения Quickstart Panel >

> Start here следует выбрать Import

Example project(s), после чего откроет�

ся одноимённое окно. В поле Project
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Рис. 9. Диалоговое окно New LPCXpresso C Project выбора семейства МК целевой системы
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arhive этого окна указываем путь к ар�

хиву с проектами, например: C:\nxp\

lpcxpresso3.6\Examples\NXP\LPC1000\

LPC17xx\ CMSISv1p30_LPC17xx.zip, по�

сле чего щёлкаем на кнопке Next. По�

сле этого отрывается окно задания

каталога для распаковки выбранно�

го архива. Не изменяя заданных по

умолчанию настроек, щёлкаем в этом

окне на кнопке Finish, после чего по�

зиция табуляции папки библиотеч�

ного проекта CMSISv1p30_LPC17xx

появляется в окне проводника про�

ектов Project Explorer. К числу заго�

ловочных и исполняемых файлов

поддержки CMSIS относятся файлы

core_cm3.h, LPC17xx.h, system_LPC17xx.h,

core_cm3.c, system_LPC17xx.c, содер�

жащиеся в библиотечном проекте

CMSISv1p30_LPC17xx.

После импорта библиотечного про�

екта CMSIS можно удалить созданный

ранее исполняемый проект Pro_Led_led,

щёлкнув на его позиции табуляции

правой кнопкой мыши и выбрав в от�

крывшемся контекстном меню коман�

ду Delete, а затем создать его заново, уже

с поддержкой CMSIS (включенной па�

раметром Use CMSIS peripheral header

files and initialization code на рисунке

10). Заметим, что поддержка CMSIS су�

щественно ускоряет и облегчает напи�

сание встроенных программ.

После создания и сохранения про�

екта пользователь может запустить

его формирование, выбрав в меню

перспективы File > Build Project, или

использовать комбинацию клавиш

CTRL+B, когда позиция табуляции дан�

ного проекта выбрана курсором в окне

обозрения Project Explorer. Для запуска

формирования можно также восполь�

зоваться соответствующей командой

Build окна обозрения «быстрого запус�

ка» Quickstart Panel > Start here.

Под формированием проекта здесь

понимается процесс компиляции его

исходных файлов, а также их последу�

ющей компоновки (линковки). Фор�

мирование проекта осуществляется

CDT в последовательности, заданной в

make�файле этого проекта. Результаты

формирования и возникшие при этом

проблемы можно наблюдать в окнах

обозрений Console и Problems соответ�

ственно. Конечным результатом фор�

мирования (компоновки) проекта яв�

ляется двоичный исполняемый файл

с расширением *.axf (*.elf), который по

умолчанию генерируется в одной из

автоматически создаваемых LPCXpres�

so IDE папок Debug или Release данно�

го проекта.

После безошибочного завершения

формирования проекта можно перей�

ти к его выполнению/отладке. По�

скольку в состав LPCXpresso IDE не

входит программный симулятор це�

левого МК, производить выполне�

ние/отладку проектов в LPCXpresso

IDE можно только в «железе», т.е. в МК

конечной системы. Однако прежде

чем начать выполнение/отладку, со�

здадим в управляющей программе

нашего проекта некое функциональ�

ное наполнение, с тем чтобы можно

было наглядно наблюдать её выпол�

нение в МК.

При работе с LPCXpresso IDE автор

статьи использовал демонстрацион�

ную плату LPCXpresso не как целевую

систему, а только в качестве аппарат�

ного отладчика LPC�Link. В качестве

целевой системы использовалась от�

ладочная плата MCB1760 фирмы Keil

Software [4]. В связи с этим файл

main.c созданного ранее проекта

Pro_Led_led был дополнен неслож�

ным кодом, реализующим эффект

последовательного зажигания и га�

шения («бегущий огонь») светодио�

дов этой платы.

При использовании режима отлад�

ки LPCXpresso IDE необходимо пред�

варительно подключить к ПК ап�

паратный отладчик LPC�Link (плату

LPCXpresso) с помощью кабеля USB 2.0

A/Mini�B. В свою очередь, к отладчику

LPC�Link необходимо подключить це�

левую систему (в нашем случае отла�

дочную плату MCB1760) через разъём

JTAG, например, как показано на ри�

сунке 11. За отсутствием в распоряже�

нии автора миниатюрного десяти�

штырькового разъёма JTAG/SWD, от�

ладчик LPC�Link был подключен к

системе через один ряд контактов

16�штырькового разъёма J4 платы

LPCXpresso. Принципиальные схемы

разводки указанных разъёмов можно

найти в [2].

Для запуска режима отладки следует

выбрать в окне обозрения Quickstart

Panel > Start here > Debug, после чего

LPCXpresso IDE произведёт повторное

формирование проекта. В случае об�

наружения компилятором или компо�

новщиком каких�либо ошибок в

исходном файле (файлах) проекта пе�

речень этих ошибок отобразится в

окне Problems, при этом информация
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Рис. 11. Подключение демонстрационной платы

LPCXpresso к отладочной плате MCB1760

через JTAG

Рис. 10. Диалоговое окно задания параметров создаваемого проекта
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ПРОГРАММИРОВАНИЕ

о каждой ошибке может быть детали�

зирована.

В случае безошибочного завершения

формирования программа начинает

инициализацию отладчика LPC�Link с

открытием соответствующего окна.

При успешном завершении инициа�

лизации код программы приложения

записывается во флэш�память МК, по�

сле чего программа LPCXpresso IDE пе�

реходит в режим отладки.

Информация о действиях, произво�

димых LPCXpresso IDE и отладчиком

LPC�Link над приложением и МК при

переходе в режим отладки (формиро�

вание приложения, обнаружение и

инициализация МК, запись кода при�

ложения во флэш�память МК, верифи�

кация этого кода, сброс МК и т.д.), ото�

бражается в окне Console, как показано

на рисунке 12.

Заметим, что отладку приложения

удобнее производить не в открытой по

умолчанию перспективе разработки

Develop, а в перспективе отладки De�

bug (Window > Open Perspective >

> (Other...) > Debug). При переходе в ре�

жим отладки автоматически открыва�

ется окно обозрения Debug, как показа�

но на рисунке 13. В ходе отладки в этом

окне отображается следующая инфор�

мация:

● текущее состояние отладчика и

программы приложения: выполне�

ние (Running) или останов выпол�

нения (Suspended). В состоянии

останова в окне отображаются все

функции программы, выполнение

которых было приостановлено, на�

пример, на время передачи управле�

ния во вложенные в них функции.

При наличии нескольких уровней

вложения перечень таких функций

представлен в окне в виде стека.

Отображаемая в окне информация

может быть развёрнута;

● каждый процесс, представленный в

виде узла (символа и строки табуля�

ции) в дереве процессов.
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Рис. 12. Информация о действиях, производимых LPCXpresso IDE и отладчиком LPC�Link

над приложением и целевым МК при переходе в режим отладки
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Необходимо отметить, что многие

возможности отладки в LPCXpresso IDE

являются контекстно�зависимыми.

Если созданная пользователем рабо�

чая область содержит библиотечные

проекты, например, типа CMSIS, то воз�

можности отладки LPCXpresso IDE бу�

дут неактивны, когда пользователь бу�

дет редактировать исходный файл на

языке C, который является частью та�

кого библиотечного проекта.

В ходе отладки разработчик может

получать информацию о значениях

локальных переменных, содержащих�

ся в любой функции отлаживаемой

программы приложения. Для этого

следует щёлкнуть мышью на позиции

табуляции требуемой функции в окне

Debug, после чего текущие значения

содержащихся в ней переменных

отобразятся в окне обозрения Variables

(см. рис. 13). В режиме отладки коман�

да исходного текста, на которую будет

передано управление при следующем

шаге выполнения программы, подсве�

чивается курсором в окне редактора.

Набор команд управления отладкой

доступен через пункт меню Run пер�

спективы Debug (а также перспективы

Develop). Кроме того, кнопки этих же

команд расположены на инструмен�

тальной панели меню окна обозрения

Debug.

Команда Restart вызовет сброс МК

целевой системы, команда Resume (F8

клавиатуры ПК) – непрерывное выпол�

нение программы приложения в ре�

альном времени, команда Run to Line

(Ctrl +R) – непрерывное выполнение

программы приложения в реальном

времени с остановом на строке исход�

ного текста, отмеченной курсором в

окне редактора.

В распоряжении пользователя име�

ются также команды, позволяющие

выполнять программу приложения на

уровне исходного текста в пошаговом

режиме. Команда Step Into (F5) вызо�

вет выполнение одного шага програм�

мы с «показом» захода управления в

функцию, команда Step Over (F6) – вы�

полнение одного шага без «показа» за�

хода управления в функцию, команда

Step Return (F7) вызовет завершение

выполнения текущей функции (выход

управления из нее) и останов выполне�

ния. Подача команды Suspend приоста�

новит выполнение программы прило�

жения. Выполнение команды Terminate

(Ctrl +F2) приведёт к выходу из режима

отладки.

В ходе сеанса отладки пользователь

может устанавливать и удалять в про�

грамме приложения точки останова,

производить мониторинг значений

программных переменных, содержи�

мого, памяти, регистров и т.д.

Установка и удаление в программе

точек останова осуществляются следу�

ющими способами:

● выбором в меню Run команд Toggle

Breakpoint, Toggle Line Breakpoint (см.

рис. 13). При этом точка останова бу�

дет установлена на команде или на

строке исходного текста, отмечен�

ной курсором в окне редактора. При

передаче управления на команду

(строку) программы приложения с

установленной точкой останова

произойдёт останов выполнения

программы. При выборе в меню Run

команды Toggle Method Breakpoint

точка останова будет установлена на

входе в функцию, содержащую стро�

ку исходного текста, которая отме�

чена курсором в окне редактора.

Повторный выбор команд Toggle

Breakpoint, Toggle Line Breakpoint,

Toggle Method Breakpoint для отмечен�

ной курсором команды (строки,

функции) с установленной точкой

останова приведёт к удалению этой

точки;

● двойным щелчком левой кнопкой

мыши на нужной строке в исходном

тексте в окне редактора. При этом

точка останова будет установлена на

этой строке. Повторный двойной

щелчок на строке с установленной

точкой останова приведет к её уда�

лению;

● заданием адреса в памяти, например,

с помощью команды Set address

breakpoint из меню окна обозрения

Quick Disassemble.

Включение через меню Run настрой�

ки Skip All Breakpoints приведёт к от�

ключению (но не удалению) всех ра�

нее установленных точек останова.

Можно снова включить точки остано�

ва, сняв указанную настройку.

Информация обо всех установлен�

ных точках останова с указанием их

текущего состояния (включена/отклю�

чена) отображается в окне обозрения

Breakpoints, как показано на рисун�

ке 14. Это окно можно открыть, выб�

рав в меню Window > Show View >

> (Other...) > Breakpoints. Для отключе�

ния точки останова следует щелчком

мыши снять галочку из квадрата слева

на позиции табуляции этой точки.

Кроме того, для управления точками

останова можно воспользоваться кон�

текстным меню окна обозрения Break�

points, которое открывается щелчком

правой кнопки мыши. Установленная

точка останова индицируется кружком

с галочкой с левой стороны окна ре�

дактора напротив строки исходного

текста. Установка/удаление, включе�

ние/отключение точек останова воз�

можны как в режиме выполнения, так

и в режиме останова выполнения прог�

раммы.

Информация о текущем содержи�

мом регистров ЦПУ целевого МК до�

ступна разработчику в окне обозрения

Core Registers; его можно открыть, вы�

брав в меню Window > Show View >

> (Other...) > Core Registers. Позиции та�

буляции регистров, содержимое кото�
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Рис. 13. Главное окно перспективы Debug в режиме отладки
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рых обновлялось с момента последне�

го останова выполнения, подсвечива�

ются жёлтым цветом. Обновление те�

кущего содержимого регистров про�

изводится программой только после

останова выполнения.

Информация о текущем содержимом

специальных (периферийных) регист�

ров целевого МК доступна разработ�

чику в окне обозрения Peripherals;

оно открывается из меню Window >

> Show View > (Other...) > Peripherals. Для

отображения содержимого специаль�

ных регистров необходимо в окне

Peripherals отметить галочками пози�

ции табуляции требуемых периферий�

ных устройств. После этого побитовое

содержимое специальных регистров,

относящихся к выбранной перифе�

рии, отобразится в автоматически от�

крывшемся окне обозрения Memory.

При необходимости наблюдения со�

держимого памяти МК следует открыть

окно обозрения Memory, выбрав в

меню Window > Show View > (Other...) >

> Memory, а затем создать т.н. монитор

наблюдения требуемой области памя�

ти, щёлкнув на пиктограмме команды

Add Memory Monitor в меню обозрения

Memory. В качестве альтернативы мож�

но использовать контекстное меню ок�

на, для открытия которого следует

щёлкнуть в окне правой кнопкой мы�

ши. После этого откроется диалоговое

окно Monitor Memory, в поле которого

Enter address or expression to monitor:

необходимо задать начальный адрес в

памяти и щёлкнуть на кнопке OK. По�

сле этого в области Monitors окна Me�

mory отобразится созданный монитор

памяти (в виде заданного начального

адреса), а в области данных этого ок�

на – содержимое памяти, начиная с за�

данного адреса. Следует отметить, что

в ходе сессии отладки можно одновре�

менно открыть несколько окон обо�

зрения Memory, используя их для отоб�

ражения содержимого различных об�

ластей памяти.

Возможности программы LPCXpres�

so IDE также позволяют разработчи�

ку наблюдать дизассемблированный

текст, соответствующий загруженно�

му в целевой МК коду приложения. Для

этого необходимо открыть окно обо�

зрения просмотра дизассемблирован�

ного текста через меню Window > Show

View > (Other...) > Disassembly. Во время

останова выполнения в этом окне

отображается фрагмент дизассембли�

рованного текста участка кода прило�

жения, в пределах которого находится

управление. В режиме отладки ассем�

блерная команда исходного текста в

окне Disassembly, на которую будет пе�

редано управление при следующем

шаге выполнения программы, под�

свечивается курсором. Помимо ассем�

блерных инструкций, в дизассемб�

лированном тексте также отобра�

жаются соответствующие этим инст�

рукциям команды исходного текста на

языке C.

Фрагмент доступного для наблюде�

ния дизассемблированного текста,

отображаемый в ходе отладки в окне

Disassembly после каждого останова

выполнения программы, весьма не�

велик. Однако пакет LPCXpresso IDE

предоставляет разработчику дополни�

тельные возможности наблюдения и

анализа дизассемблированного текс�

та. Для этого необходимо сначала

открыть окно обозрения «быстрого»

просмотра дизассемблированного

текста, выбрав в меню Window > Show

View > (Other.. .) > Quick Disassemble,

затем уже в меню этого окна выбрать

команду Show disassemble dialog, после

чего откроется диалоговое окно Disas�

semble. Кроме того, можно использо�

вать контекстное меню окна Quick Di�

sassemble, для открытия которого сле�

дует щёлкнуть в окне правой кнопкой

мыши. В поле Start address or function

окна Disassemble следует задать началь�

ный адрес в памяти (или название

функции), с которого будет осущест�

вляться «быстрое» отображение дизас�

семблированного текста программы,

в поле Length – требуемый размер

фрагмента дизассемблированного ко�

да в байтах, и щёлкнуть на кнопке OK.

После этого в окне Quick Disassemble

отобразится дизассемблированный

текст, соответствующий заданному

участку памяти приложения.

Продолжение следует
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Рис. 14. Окно обозрения точек останова Breakpoints
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