
ОБЩЕЕ ОПИСАНИЕ IDE IAR
EMBEDDED WORKBENCH™

Программная среда IAR EWARM [1,

2] относится к числу сред, регулярно

обновляемых производителем (на

момент написания этой статьи выш�

ла версия 4.41A), имеет простые инту�

итивно понятные правила работы и

поддерживает в числе прочих широ�

ко распространённый аппаратный

отладочный драйвер JTAG Wiggler, ис�

пользование которого будет описано

ниже. Бесплатные демоверсии IAR

EWARM в двух вариантах – с ограни�

ченным сроком действия (1 месяц),

но без ограничения объёма компили�

руемого кода, и с неограниченным

сроком действия, но с ограниченным

объёмом кода (32 К), – доступны на

сайте www.iar.com. IAR EWARM позво�

ляет создавать законченные приклад�

ные проекты на базе 8�, 16� и 32�раз�

рядных МК различных производите�

лей и в том числе на базе МК с ядрами

ARM. IDE включает в себя набор

инструментальных средств, интегри�

рованных в единую программу�обо�

лочку с удобным оконным интерфей�

сом, работающую под Windows

Microsoft:

● компилятор IAR ARM C/C++,

● ассемблер IAR ARM,

● универсальный компоновщик IAR

XLINK Linker™,

● программа построения библиотек

IAR XAR Library Builder™,

● набор библиотек IAR XLIB Libra�

rian™,

● текстовый редактор для подготов�

ки исходных текстов программ,

● менеджер проектов,

● утилита построения командной

строки,

● отладчик языка высокого уровня

IAR C�SPY Debugger™.

Компилятор, ассемблер и компо�

новщик могут запускаться на выпол�

нение не только из оболочки IDE, но

и из командной строки, поддержка

которой обеспечивается соответству�

ющей утилитой IAR EWARM. Запуск из

командной строки применяется в

случае, когда есть необходимость ис�

пользовать компилятор, ассемблер и

компоновщик как внешние инстру�

ментальные средства в уже установ�

ленной проектной среде.

IDE IAR Embedded Workbench под�

держивает развитые функции управ�

ления проектами, дающие возмож�

ность пользователю управлять всеми

проектными модулями, например,

файлами исходного текста на C или

C++, ассемблерными файлами, под�

ключаемыми файлами и другими свя�

занными модулями. Файлы могут быть

сгруппированы с различными опция�

ми, заданными на уровне всего проек�

та, группы или только файла. Сам про�

ект в целом, а также относящиеся к не�

му группы файлов и отдельные файлы

называются узлами. При этом проект в

целом является узлом самого верхнего

уровня, а отдельные файлы – узлами

самого низкого уровня. Под проект�

ным модулем понимается файл.

Для управления проектами IDE

предоставляет следующие основные

средства и возможности:

● шаблоны для создания проектов;

● иерархическое представление про�

екта;

● браузер исходного файла с иерар�

хическим символьным представле�

нием;

● установка опций глобально, для

групп исходных файлов или для ин�

дивидуальных исходных файлов;

● утилита Make, которая перетранс�

лирует, повторно ассемблирует и

компонует файлы, когда это необ�

ходимо;

● текстовые файлы проектов;

● утилита Custom Build, разворачива�

ющая стандартный инструмен�

тальный набор простым способом;

● командная строка, формирующая

проектный файл на входе.

СТРУКТУРА IAR EMBEDDED

WORKBENCH™
В ходе инсталляции IDE IAR Embed�

ded Workbench на жёстком диске

компьютера создаётся несколько ка�

талогов, содержащих различные ти�

пы файлов, используемых IDE. Ниже

приводится описание файлов, содер�

жавшихся по умолчанию в каждом

каталоге.

Корневой каталог, создаваемый по

умолчанию инсталляционной про�

цедурой, находится по пути:

x:\Program Files\IAR Systems\ Embedded
Workbench 4.n\ <директории IDE>,

где x – диск, на котором установлена

операционная система Windows Mic�

rosoft, 4.n – номер версии IDE IAR

Embedded Workbench.

В каталоге Embedded Workbench 4.n
содержатся два подкаталога: common

и ARM. 

Подкаталог common содержит под�

каталоги компонентов, общих для

всех программ IDE IAR Embedded

Workbench™.

Подкаталог common\bin содержит

исполняемые файлы компонентов,
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Предлагаемая вниманию читателей статья является логическим

продолжением ранее опубликованного цикла, описывающего

архитектуру и способы программирования микроконтроллеров

(далее – МК) семейства LPC2000. В этой статье будет рассказано

о порядке и способах разработки$отладки пользовательских проектов

на базе МК LPC2000 в интегрированной среде IDE IAR Embedded

Workbench™ (IAR EWARM) с компилятором Си от фирмы IAR.

Эта широко распространённая отладочная среда является мощной

альтернативой конкурирующей среды μVISION с компилятором Си

от компании Keil Elektronik. Помимо этого статья содержит подробную

информацию о способах записи в МК LPC2000 пользовательских

программ.

Разработка и отладка проектов
на базе МК LPC2000

Павел Редькин (г. Ульяновск)



общих для всех программ IDE IAR

Embedded Workbench, типа IAR XLINK

Linker, IAR XLIB Librarian, IAR XAR

Library Builder, редактор и графичес�

кий пользовательский интерфейс.

Здесь также расположен исполняе�

мый файл IAR Embedded Workbench.

Подкаталог common\config содержит

файлы, используемые IAR Embedded

Workbench для того, чтобы поддержи�

вать параметры настройки IDE.

Подкаталог common\doc содержит

справочные файлы (readme) с допол�

нительной информацией о компо�

нентах, общих для всех программ IAR

Embedded Workbench™. Каталог так�

же содержит интерактивную версию

руководства IAR Linker and Library
Tools Reference Guide в формате PDF.

Подкаталог common\src содержит

исходные файлы для компонентов,

общих для всех программ IAR Embed�

ded Workbench™ в выходном форма�

те SIMPLE.

Подкаталог common\plugins содер�

жит исполняемые файлы и файлы

описаний для компонентов, которые

могут быть загружены как сменные

модули.

Подкаталог ARM содержит подката�

логи, определяемые спецификой

продуктов ARM, поддерживаемых IAR

Embedded Workbench.

Подкаталог arm\bin содержит ис�

полняемые файлы для специфичес�

ких компонентов ARM, типа компи�

лятора ARM IAR C/C++, ARM IAR ассем�

блера и драйверов IAR C�SPY™.

Подкаталог arm\config содержит

файлы, используемые для разработ�

ки проектов, например:

● шаблоны командного файла ком�

поновщика (*.xcl),

● параметры настройки МК (*.i79),

● файлы описания устройства C�SPY

(*.ddf),

● синтаксическая «окраска» файлов

конфигурации (*.cfg),

● шаблоны для прикладных и библи�

отечных проектов (*.ewp), соответ�

ствующие им библиотечные фай�

лы конфигурации.

Подкаталог arm\doc содержит спра�

вочные файлы (readme) с дополни�

тельной информацией об инструмен�

тальных средствах ARM. Каталог также

содержит интерактивные версии не�

скольких руководств по специфичес�

ким компонентам ARM в формате PDF.

Подкаталог arm\inc содержит фай�

лы, рекомендуемые для использова�

ния в качестве подключаемых, типа

файлов заголовка для стандартных

библиотек C или C++. В подкаталоге

содержатся также заголовочные фай�

лы, определяющие регистры специ�

альных функций (SFR) МК. Эти фай�

лы используются компилятором и ас�

семблером.

Подкаталог arm\lib содержит пред�

варительно подготовленные библио�

теки и библиотеки файлов конфигу�

рации, используемые компилятором.

Подкаталог arm\plugins содержит

исполняемые файлы и файлы описа�

ния для компонентов, которые могут

быть загружены как сменные модули.

Подкаталог arm\src содержит ис�

ходные файлы для некоторых библи�

отечных функций с перестраивае�

мой конфигурацией и примеры кода

приложений. Этот каталог также со�

держит исходный код библиотек.

Подкаталог arm\drivers содержит

дистрибутивы драйверов JTAG�ин�

терфейса (например, Wiggler), кото�

рые могут быть проинсталлированы

на компьютер хоста и позволяют

производить отладку пользовательс�

ких проектов и загрузку пользова�

тельских программ в память МК целе�

вых пользовательских систем.

Подкаталог arm\tutor содержит

файлы демонстрационных обучаю�

щих проектов, которые могут ис�

пользоваться для освоения пользова�

телями работы с IDE.

Подкаталог arm\examples содержит

примеры работающих проектов на

базе МК различных производителей

и семейств.

СОЗДАНИЕ ПРОЕКТОВ

ПРИЛОЖЕНИЙ В IDE
Параметры, используемые для

настройки нового проекта

IDE IAR Embedded Workbench поз�

воляет создавать простые и расши�

ренные проектные модели. При соз�

дании расширенной проектной моде�

ли сначала создаётся рабочая об

ласть, к которой добавляется один

или несколько проектов. В IDE име�

ются готовые шаблоны проектов как

для прикладных, так и для библиотеч�

ных проектов. Каждый проект может

содержать иерархию из групп, в кото�

рые собираются исходные файлы
пользователя. Для каждого проекта

может быть определена одна или не�

сколько конфигураций компоновки.

Поскольку рассмотренный ниже

пример приложения является прос�

тым проектом с малым количеством

файлов, для него нет необходимости

в расширенной проектной модели.

Производитель рекомендует, чтобы

при создании нового проекта пользо�

ватель создавал отдельный каталог,

где сохранялись бы все файлы этого

проекта. Прежде чем создать проект,

необходимо сначала создать рабочую

область (окно рабочей области).

Создание окна рабочей области

Первый шаг при создании нового

проекта заключается в создании но�

вой рабочей области. При запуске IAR

Embedded Workbench первый раз

имеется уже готовая автоматически

созданная рабочая область, которую

сразу же можно использовать для

проектов. Если разработчик исполь�

зует эту рабочую область, то первый

шаг можно игнорировать:

1. Выбрать в меню File>New и выбрать

Workspace в диалоговом окне New.

«Кликнуть» мышью на кнопке OK,

после чего отобразится пустое ок�

но рабочего рабочей области;

2. Чтобы сохранить созданную рабо�

чую область, необходимо выбрать в

меню File>Save Workspace, а затем

задать, где должен быть сохранён

файл рабочей области, набрав его

имя в поле File name и нажав кноп�

ку Save. По умолчанию этот файл

сохраняется в каталоге projects.

Файл рабочей области будет иметь

расширение имени файла eww.

Этот файл содержит перечисление

всех проектов, которые пользова�

тель добавляет к данной рабочей

области. Информация, связанная с

текущим сеансом, типом и разме�

щением окон и контрольных точек,

содержится в файлах, создаваемых

в каталоге projects\settings. Теперь

можно создать сам проект и доба�

вить его к рабочей области.

Следует заметить, что сохранить

рабочую область вышеописанным

способом можно будет только после

создания в ней хотя бы одного ново�

го проекта (см. ниже).

Создание нового проекта

Создание нового проекта произво�

дится в такой последовательности:

1. Выбрать в меню Project>Create New
Project. Появившееся диалоговое

окно Create New Project предостав�

ляет возможность использования в

качестве основы нового шаблона

проекта. В общем случае можно

выбрать шаблон Empty project, ко�
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торый просто создаёт проект, ис�

пользующий заданные по умолча�

нию параметры настройки;

2. В поле Tool chain выбрать ARM и

«кликнуть» на кнопке OK;

3. В появившемся стандартном диа�

логовом окне Save As следует опре�

делить, где требуется сохранить

файл проекта, например, в каталоге

projects. В поле File name следует на�

писать имя файла проекта, напри�

мер, project1, и нажать на кнопку

Save, чтобы завершить создание но�

вого проекта. Проект появится в ок�

не рабочей области.

По умолчанию создаются две кон�

фигурации компоновки: отладки и

выгрузки (Debug и Release). В приве�

дённом далее примере будет исполь�

зоваться только конфигурация отлад�

ки Debug. Конфигурация компоновки

выбирается из раскрывающегося ме�

ню в верхней части окна рабочей об�

ласти. Звёздочка на имени проекта

указывает, что произведённые изме�

нения не были сохранены.

Файл проекта с расширением име�

ни файла ewp теперь создан в катало�

ге projects. Этот файл содержит ин�

формацию о параметрах настройки

проекта, например, таких, как вари�

ант компоновки.

Добавление файлов к проекту

Любой мало�мальски сложный про�

ект, как правило, содержит не один, а

несколько файлов: исходный текст

основной программы, исходные текс�

ты поддержки аппаратных модулей,

заголовочные файлы к ним и т.д.

Возможность создания нескольких

групп позволяет организовать исход�

ные файлы, входящие в состав проек�

та, в соответствии с их содержимым

или согласно иным потребностям

пользователя. В данном проекте бу�

дет только два файла, поэтому нет ни�

какой необходимости создавать

группу.

Добавление файлов к проекту произ�

водится в такой последовательности:

1. В окне рабочей области курсором

выбрать объект, к которому плани�

руется добавить исходный файл,

Это может быть группа или, как в

нашем случае, непосредственно

проект;

2. Выбрать в меню Project>Add Files, по�

сле чего откроется стандартное диа�

логовое окно обзора файлов и ката�

логов. Поочерёдно выбираем файлы

из списка и нажимаем кнопку Open.

После этого выбранные файлы до�

бавляются к проекту project1.

Задание опций проекта

Для прикладных пользовательских

проектов опции могут быть заданы

для узлов проекта всех уровней. Сна�

чала производится задание генераль�

ных (общих) опций, например, таких

как конфигурация процессора. Эти

опции должны быть одинаковыми

для всей структуры конфигурации,

поэтому они устанавливаются для уз�

ла уровня проекта.

Задание опций проекта произво�

дится в такой последовательности:

1. Выбирается позиция табуляции нуж�

ного проекта, например, project1 –
Debug в окне рабочей области, а в ме�

ню выбирается Project>Options. По�

сле этого откроется страница Target в

категории General Options. На стра�

ницах General Options следует прове�

рить установки параметров настрой�

ки, приведённые в табл. 1. Необходи�

мо заметить, что задание типа ядра

МК (например, ARM7TDMI�S) опцией

Core в поле Processor variant произво�

дится только в случае, если создавае�

мый проект предназначен, напри�

мер, для программной симуляции

без последующего переноса его в па�

мять целевой пользовательской сис�

темы. В случае, если проект создается

под конкретную модель МК, можно

непосредственно задать нужное уст�

ройство опцией Device, выбрав его из

открывающегося списка. После уста�

новки глобальных опций следует ус�

тановить опции компилятора для

проекта.

2. Выбрать C/C++ Compiler в списке

Category, с тем чтобы отобразить

страницы группы опций компиля�

тора.

3. Проверить установки параметров

настройки, приведённые в табл. 2.

4. «Кликнуть» на кнопке OK, чтобы

установить значения, которые бы�

ли выбраны.

На этом этапе создание нового про�

екта можно считать законченным.

Компилирование файлов

приложения

После создания проекта приложе�

ния следует его откомпилировать и

скомпоновать. При этом создаётся

файл листинга компилятора и файл

карты компоновщика.

Компилирование исходных фай�

лов производится в такой последова�

тельности:

1. Чтобы откомпилировать, напри�

мер, файл Utilities.c, следует выбрать

его в окне рабочей области;

2. Выбрать в меню Project>Compile.

Альтернативно можно нажать на

кнопку Compile в инструменталь�

ной панели или выбрать команду

Compile из контекстного меню, ко�

торое появляется, если щёлкнуть

правой кнопкой мыши на выбран�

ном файле в окне рабочей области.

Процесс и результаты компиляции

будут отображаться в окне сообще�

ний Build;

3. Откомпилировать файл Tutor.c тем

же самым способом.

По завершении компиляции IAR

Embedded Workbench создаст новые

подкаталоги в каталоге проекта. По�

скольку нами используется конфигу�

рация компоновки Debug, то в ката�

логе Debug будут созданы каталоги

List, Obj и Exe:

● каталог List – каталог хранения

файлов листинга. Файлы листинга

имеют расширение lst;
● каталог Obj – каталог хранения

объектных файлов компилятора и

ассемблера. Эти файлы имеют рас�

ширение r79 и в дальнейшем будут

использоваться как входные для

компоновщика IAR XLINK;

● каталог Exe – каталог хранения ис�

полняемого файла. Этот файл име�

ет расширение d79 и в дальнейшем

будет использоваться как входной

для отладчика IAR C�SPY. Следует

заметить, что этот каталог будет ос�

таваться пустым, пока не будет

произведена компоновка объект�

ных файлов.

«Кликните» на значке «+» в окне ра�

бочей области, чтобы полностью раз�

вернуть дерево файлов проекта. Как

можно видеть, IAR Embedded Work�

bench в результате компиляции соз�
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Таблица 1. Глобальные параметры настройки

для проекта project1

Таблица 2. Параметры настройки компилятора

C/C++ для проекта project1

Страница окна Параметр: значение

Target Core: ARM7TDMI�S

Output Output file: Executable

Library Configuration Library: Normal

Страница окна Параметр: значение

Code Optimizations, Size: None
(Best debug support)

Output Generate debug information

List Output list fileAssembler mnemonics



дал в рабочей области позицию табу�

ляции папки Output, в которой содер�

жатся все созданные выходные фай�

лы. В дереве проекта отображаются

также все подключаемые файлы заго�

ловков.

Для того чтобы открыть любой

файл из окна рабочей области в окне

редактора IAR Embedded Workbench,

например, для редактирования, необ�

ходимо дважды «кликнуть» на его

имени в окне рабочей области.

Компоновка приложения

На этапе компоновки необходимо

задать опции настройки компонов�

щика IAR XLINK Linker™. Для этого

нужно выполнить определённую по�

следовательность действий:

1. Выбрать позицию табуляции нуж�

ного проекта, например, project1 –

Debug в окне рабочей области, а за�

тем выбирать в меню Pro

ject>Options. После этого выбрать

строку Linker в списке Category, что�

бы отобразить страницы опций

компоновщика XLINK;

2. Задать установки параметров на�

стройки в соответствии с табл. 3.

При компоновке следует выбирать

такой формат выходного файла

компоновщика (Output file), кото�

рый соответствует дальнейшим це�

лям пользователя. Если планирует�

ся загрузить выходной файл в от�

ладчик, то выходной файл должен

содержать информацию отладки.

Если планируется загрузить выход�

ной файл в программатор PROM, то

выходной файл не должен содер�

жать информацию отладки и быть,

например, в формате Intel�hex или

Motorola S�records. Для своей рабо�

ты компоновщик использует кома�

ндный файл, который задаётся на

странице Config опций компонов�

щика XLINK. Для данного проекта

командный файл компоновщика

не используется. Командные фай�

лы компоновщика для некоторых

оценочных плат и МК находятся в

src/examples, о чём будет подробнее

рассказано ниже. Для получения

дополнительной информации о

командных файлах компоновщика

рекомендуется обратиться к [3, 4];

3. «Кликнуть» на кнопке OK, чтобы

сохранить установленные опции

XLINK. Теперь можно скомпоно�

вать объектный файл и сгенериро�

вать код, который в дальнейшем

может быть отлажен;

4. Выбрать в меню Project>Make. Ход

процесса компоновки будет отоб�

ражаться в сообщениях в окне ком�

поновки. В результате компоновки

будет создан файл project1.d79, со�

держащий код с информацией от�

ладки, и файл карты компоновщи�

ка project1.map.

ОТЛАДКА ПРИЛОЖЕНИЯ

В РЕЖИМЕ СИМУЛЯЦИИ

Встроенный в IDE EWARM отладчик

IAR C�SPY Debugger является отладчи�

ком языка высокого уровня. Он пред�

назначен для использования с компи�

лятором ARM IAR C/C++ Compiler и с

ассемблером ARM IAR Assembler и пол�

ностью интегрирован в IAR IDE, обес�

печивая одновременную разработку и
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Таблица 3 Параметры настройки XLINK

для проекта project1

Страница окна Параметр: значение

Output
Debug information for C�SPY
With runtime control modules
With I/O emulation modules

List
Generate linker listing

Segment map
Symbols: Module map

• Диапазон частот: до 4 ГГц
• Напряжение питания: 28...48 В
• Мощность: 10...60 Вт
• КПД: > 45%
• Температура перехода: > 255°С
• Наработка на отказ (MTTF) SIC СВЧ"приборов:

2,2 млн. часов при +225°С
60 млн. часов при +175°С

Высокотемпературные радиационностойкие

SiC и GaN СВЧ"транзисторы

Ре
кл

ам
а

ПРОСОФТ – официальный дистрибьютор компании Cree 

ПРОСОФТ — АКТИВНЫЙ КОМПОНЕНТ ВАШЕГО БИЗНЕСА
Телефон: (495) 232�2522 • E�mail: info@prochip.ru • Web: www.prochip.ru 



отладку пользовательского приложе�

ния. При запуске C�SPY Debugger все

окна, открытые в этот момент в рабо�

чей области, останутся открытыми.

Кроме того, будет открыт набор спе�

цифических окон C�SPY. Пользова�

тель может изменить исходный текст

своей программы в окне редактора в

течение сеанса отладки, однако, эти

изменения не вступят в силу, пока не

будет произведён выход из отладчика.

Интеграция отладчика в IDE позволя�

ет установить контрольные точки

средствами текстового редактора в

любом месте пользовательской про�

граммы в ходе её написания и редак�

тирования. Также можно просматри�

вать и изменять контрольные точки,

когда отладчик не выполняется.

В качестве примера работы с от�

ладчиком IAR C�SPY Debugger рас�

смотрим отладку приложения pro

ject1.d79, создание которого было

описано в предыдущем разделе. В

процессе отладки пользователь мо�

жет наблюдать за переменными, ус�

танавливать контрольные точки,

просматривать код в режиме дизас�

семблирования, управлять содержи�

мым регистров и памяти и выводить

на печать выходные данные прог�

раммы в терминальном окне ввода�

вывода.

Перед стартом отладчика IAR C�SPY

Debugger необходимо задать несколь�

ко его опций. Задание опций произ�

водится в такой последовательности:

1. Выбрать в меню Project>Options, а

затем категорию Debugger. На стра�

нице Setup убедиться, что выбрана

строка симулятор Simulator из рас�

крывающегося списка Driver и

пункт Run to main. «Кликнуть»

мышью на кнопке OK;

2. Выбрать Project>Debug. Альтерна�

тивно можно нажать кнопку

Debugger в инструментальной па�

нели. Старт отладчика IAR C�SPY

Debugger производится с загружен�

ным приложением project1.d79. В

дополнение к окнам, уже открытым

в IAR Embedded Workbench, пользо�

вателю теперь станет доступен на�

бор специфических окон IAR C�SPY

Debugger.

Для просмотра команд исходного

текста необходимо выполнить следу�

ющие действия:

1. Дважды «кликнуть» мышью на фай�

ле Tutor.c в окне рабочей области;

2. Когда содержимое файла Tutor.c
отобразится в окне редактора, сле�

дует выбрать команду Debug>Step
Over. Альтернативно можно нажать

на кнопку Step Over на инструмен�

тальной панели. После этого в текс�

те отображаемого файла появится

курсор, текущая позиция которого

будет вызовом функции init_fib, как

показано на рис. 1; 

3. Выбрать в меню Debug>Step Into для

показа передачи управления в

функцию init_fib. Альтернативно

можно нажать кнопку Step Into на

инструментальной панели.

На уровне исходного текста коман�

ды отладчика Step Over и Step Into поз�

воляют выполнять пользовательское

приложение в пошаговом режиме.

Выполненная команда Step Over пока�

зывает передачу управления с захо�

дом его внутрь функций или вызовов

подпрограмм, а при выполнении ко�

манды Step Into передача управления

каждой функции показывается как

единственный шаг без захода его

внутрь функции. Пошаговое движе�

ние при выполнении приложения

производится на уровне вызова функ�

ций, а не на уровне операторов. Чтобы

пошаговое движение производилось

на уровне операторов, следует вы�

брать команду Debug>Next statement.
После этого за один шаг будет выпол�

няться один оператор. Альтернативно

можно нажать на кнопку Next state

ment на инструментальной панели.

C�SPY позволяет наблюдать пере�

менные или выражения в исходном

тексте таким образом, чтобы можно

было следить за их значениями в

процессе симуляции выполнения

приложения. Наблюдать перемен�

ную можно несколькими способами,

например, устанавливая мышью в ок�

не исходного текста указатель или

открывая одно из окон Locals, Watch,

Live Watch или Auto.

Следует заметить, что когда исполь�

зуется уровень оптимизации None,

все нестатические переменные пол�

ностью доступны для отладки. Когда

используются более высокие уровни

оптимизации, для отладки пол�

ностью доступны не все переменные.

Отладчик IAR C�SPY Debugger со�

держит мощную систему точек оста�

нова. Самый удобный путь её исполь�

зования состоит в том, чтобы уста�

навливать точки останова в интерак�

тивном режиме, позиционируя кур�

сор на требуемой команде исходного

теста или около неё, а затем выбирая

команду Toggle Breakpoint. Установка

точек останова производится в такой

последовательности:

1. Пусть требуется установить точку

останова на команде get_fib(i).

Сначала «кликните» на позиции

табуляции Utilities.c в окне редак�

тора, а затем «кликните» на требуе�

мой команде, чтобы позициони�

ровать на ней курсор. После этого

выберите Edit>Toggle Breakpoint.

Альтернативно можно нажать

кнопку Toggle Breakpoint на инст�

рументальной панели. Точка оста�

нова будет установлена на этой ко�

манде, а на левом краю окна нап�

ротив команды появится красный

значок «X», указывающий на уста�

новленную точку останова, как по�

казано на рис. 2;

2. Чтобы выполнять приложение

только до тех пор, пока управление

не достигнет точки останова, следу�

ет выбирать в меню Debug>Go. Аль�

тернативно можно нажать кнопку

Go на инструментальной панели.

Приложение выполнится до точки

останова, которая была установле�

на ранее. При передаче управления

на точку останова выполнение

программы будет приостановлено,

а команда будет подсвечена;

3. Чтобы удалить ранее установлен�

ную точку останова, следует выби�

рать в меню Edit>Toggle Breakpoint.
Окно Register позволяет разработ�

чику наблюдать и модифицировать

содержимое регистров процессора.

Окно Memory позволяет разработ�

чику наблюдать содержимое выбран�

ных областей памяти. Можно, напри�

мер, просмотреть область памяти, со�

ответствующую переменным root.
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Рис. 1. Просмотр команд исходного текста

Рис. 2. Установка точек останова



Мониторинг памяти осуществляется

следующим образом:

1. Выбрать View>Memory, чтобы отк�

рыть окно Memory;

2. Сделать активным окно Utilities.c и

выбрать root, а затем перетащить

его из окна исходного файла на C в

окно Memory. При этом в окне

Memory будет показано содержи�

мое области памяти, соответствую�

щей расположению переменной

root;
3. Чтобы отобразить содержимое па�

мяти в виде 16�разрядных слов дан�

ных, выберите команду Memory16 в

выпадающем меню на инструмен�

тальной панели окна Memory.

Можно вручную модифицировать

содержимое памяти, редактируя зна�

чения в окне Memory. Для этого следует

поместить курсор на ячейку памяти,

подлежащую редактированию, и наб�

рать с клавиатуры её новое значение.

Для выхода из C�SPY следует вы�

брать Debug>Stop Debugging. Альтер�

нативно можно нажать на кнопку

Stop Debugging на инструментальной

панели. На экране отобразится рабо�

чая область.

ИСПОЛЬЗОВАНИЕ БИБЛИОТЕК

При работе над большим проектом

у разработчика, как правило, накап�

ливается коллекция полезных под�

программ, которые впоследствии

можно использовать и в других при�

ложениях. С целью избежать необхо�

димости транслировать эти подпро�

граммы всякий раз, когда в них есть

необходимость, разработчик может

сохранить такие подпрограммы как

объектные файлы, которые оттранс�

лированы, но не скомпонованы. Кол�

лекция подпрограмм в отдельном

объектном файле называется библи�

отекой. Использование библиотеч�

ных файлов рекомендуется, чтобы

создавать коллекции связанных под�

программ, образующих драйверы

устройства.

Для формирования библиотек слу�

жит входящая в IAR Embedded Work�

bench программа построения библи�

отек IAR XAR Library Builder™. Прог�

рамма позволяет следующим обра�

зом управлять библиотеками:

● изменять тип модулей с PROGRAM

на LIBRARY и наоборот;

● добавлять или удалять модули из

библиотечного файла;

● создавать листинг имен модулей,

имен точек входа, и т.д.

Для получения дополнительной

информации об использовании биб�

лиотек и создании библиотечных

проектов рекомендуется обратиться

к книге [5].

УНИВЕРСАЛЬНЫЙ

КОМПОНОВЩИК

IAR XLINK LINKER™
Компоновщик (линковщик) IAR

XLINK преобразует один или более

перемещаемых объектных файлов,

которые являются продуктами рабо�

ты ассемблера IAR или компилятора,

в машинный код для выбранного

процессора целевой пользовательс�

кой системы.

Компоновщик IAR XLINK поддер�

живает пользовательские библиоте�

ки и включает в машинный код толь�

ко те библиотечные модули, которые

фактически необходимы программе,

с которой они связаны.

Конечным продуктом работы ком�

поновщика IAR XLINK является абсо�

лютный, пригодный для выполне�

ния в целевой пользовательской

системе объектный файл, который

может быть записан в оперативную

или постоянную память МК, загру�

жен в аппаратный эмулятор или мо�

жет выполняться непосредственно в

хосте с использованием отладчика

IAR C�SPY Debugger (в режиме симу�

ляции).

При компоновке программы ком�

поновщик IAR XLINK выполняет че�

тыре различных функции:

● преобразует в загрузочные модули

исполняемый код или данные из

входного файла (файлов);

● с в я з ы в а е т р а з л и ч н ы е м о д у л и

вместе, разрешая применение

глобальных, т.е. используемых

всей программой символов, при�

менение которых не могло быть

разрешено ассемблером или ком�

пилятором;

● преобразует в загрузочные модули,

необходимые программе, опреде�

лённые пользователем IAR�библио�

теки;

● задаёт местоположение каждого

сегмента кода или данных в опре�

делённом пользователем адресе.

НАСТРОЙКИ XLINK В IDE
IAR EMBEDDED WORKBENCH

При выборе в главном меню IDE

пункта Project>Options и последую�

щего выбора строки Linker в списке

Category откроется окно отображе�

ния страниц опций XLINK. На стра�

нице Output этого окна можно вы�

брать требуемый формат выходного

файла компоновщика. Если активи�

зировать кнопку Debug information for
C
SPY, то выходной файл XLINK будет

содержать информацию отладки. Ес�

ли активизировать кнопку Other, то в

списках Output format и Format vari

ant можно выбрать формат выходно�

го файла XLINK под требуемую аппа�

ратную платформу и дополнительно

задать его варианты. Следует заме�

тить, что для загрузчика LPC2000 ISP

(BootLoader) требуется задать формат

выходного файла intel
extended. Для

отладчика C�SPY лучше всего выбрать

совокупное задание опций Debug
information for C
SPY, With runtime con

trol modules и With I/O emulation mo

dules.

Поле Output file можно использо�

вать, если есть необходимость сме�

нить имя и/или расширение выход�

ного файла.

На странице Config окна отображе�

ния страниц опций XLINK в области

Linker command file можно задать путь

к используемому командному файлу

компоновщика с картой памяти вы�

бранного МК (с расширением xcl)
или, используя кнопку Command file
configuration tool, открывающую од�

ноименное окно редактирования,
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Рис. 3. Взаимодействие отладчика C#SPY Debugger и целевой пользовательской системы



создать, редактировать и сохранить

командный файл вручную. 

В качестве командных файлов ком�

поновщика для устройств LPC2000

при разработке реальных проектов

нами будут использоваться файлы

LPC2129_FLASH.xcl и LPC2129_SRAM.xcl,
предназначенные для использования

в проектах на базе МК LPC2129. Эти

файлы вместе с командными фай�

лами компоновщика для других

устройств семейства LPC2000 сво�

бодно распространяются произво�

дителем, а также имеются в составе

IAR EWARM. Командный файл

LPC2129_FLASH.xcl позволяет компо�

новщику генерировать объектный

код, предназначенный для записи во

Flash�память устройства LPC2129, а

командный файл LPC2129_SRAM.xcl –
код, предназначенный для записи в

оперативную память (SRAM)

LPC2129. Запись кода в SRAM с его

последующим выполнением может

использоваться разработчиком для

отладки пользовательских программ

непосредственно в МК целевой сис�

темы, но без расходования ресурса

циклов стирания�записи встроенной

Flash�памяти МК.

ОТЛАДКА ПРИЛОЖЕНИЙ

В ЦЕЛЕВОЙ СИСТЕМЕ

Входящий в состав IDE IAR Embed�

ded Workbench отладчик IAR C�SPY

Debugger наряду с отладкой в режиме

симуляции может быть использован

для отладки непосредственно в «же�

лезе», т.е. в составе целевой системы.

Блок�схема, показывающая общую

структуру отладчика IAR C�SPY De�

bugger и способы его взаимодействия

с целевой системой, приведена на

рис. 3. Целевая система может состо�

ять из аппаратных средств оценоч�

ной платы или аппаратных средств

конкретного пользовательского уст�

ройства. Целевая система может так�

же полностью или частично модели�

роваться программным обеспечени�

ем. Для каждого отдельного типа це�

левой системы может использоваться

специализированный драйвер C�SPY.

В рамках данной статьи будет рас�

сматриваться вариант отладки в це�

левой системе, когда пользовательс�

кая прикладная программа выполня�

ется в SRAM МК (в нашем случае –

LPC2129). Для загрузки программы в

SRAM и её корректного выполнения

необходимо соблюдение двух основ�

ных условий:

1. Использование соответствующего

командного файла компоновщика.

Например, для устройства LPC2129

следует использовать файл

LPC2129_ SRAM.xcl;
2. Корректная инициализация специ�

ального регистра МК MEMMAP, ко�

торый управляет переотображени�

ем в адресном пространстве памяти

векторов прерываний LPC2000. Для

выполнения программы в SRAM ре�

гистр MEMMAP должен быть ини�

циализирован значением 2.

Разумеется, помимо перечислен�

ных условий необходимо также

подключить хост с отладчиком к це�

левой системе, а также соответствую�

щим образом настроить аппаратные

средства отладчика, о чём будет рас�

сказано ниже.

Отладчик IAR C�SPY состоит из об�

щей для всех драйверов части, кото�

рая обеспечивает основной набор

операций отладки, и драйвера (драй�

веров). Драйвер C�SPY – это его часть,

которая обеспечивает связь с целе�

вой системой и управление ею. Драй�

вер C�SPY имеет пользовательский

интерфейс в виде специального ме�

ню, окон и диалоговых окон, отобра�

жающих определённые функции це�

левой пользовательской системы.

В рамах этой статьи описывается

драйвер JTAG�интерфейса Macraigor

(по названию фирмы�производите�

ля), с помощью которого в дальней�

шем нами будет производиться от�

ладка пользовательских приложений

и их загрузка в память МК LPC2000.

Этот драйвер позволяет задавать не�

которое ограниченное количество

точек останова кода и контрольных

точек данных, а также производить

выполнение кода в реальном време�

ни с обработкой прерываний. Драй�

вер Macraigor не занимает никакого

объёма в памяти МК, поскольку его

код размещён целиком в хосте.

Блок�схема, отображающая струк�

туру связи хоста с целевой пользова�

тельской системой при использова�

нии драйвера JTAG�интерфейса Mac�

raigor, приведена на рис. 4.

Драйвер IAR C�SPY Macraigor может

соединяться со встроенным интер�

фейсным модулем JTAG МК через ап�

паратные интерфейсы (кабели) Wig�

gler или mpDemon. Нами будет ис�

пользоваться интерфейс Wiggler. Он

выполнен в виде кабеля и подключа�

ется к параллельному порту компью�

тера хоста. Используемый драйвером

Wiggler интерфейс JTAG МК – станда�

ртное встроенное отладочное подк�

лючение, доступное в большинстве

процессоров ARM, в том числе и в уст�

ройствах LPC2000.

Для задания драйвера отладчика C�

SPY в меню IAR Embedded Workbench

следует выбирать Project>Options. В

открывшемся окне Options следует

выбрать категорию Debugger, после

чего в этой категории откроется

страница Setup. Выбор драйвера для

отладчика производится в поле

Driver этой страницы. Для работы с

кабелем Wiggler необходимо выб�

рать Macraigor. Для настройки выб�

ранного драйвера JTAG Macraigor

следует в окне Options выбрать кате�

горию Macraigor, после чего в этой

категории откроется одноименная

страница. В этой странице необхо�

димо задать настройки следующих

полей:

● OCD Interface device – выбор уст�

ройства JTAG�конвертера. В нашем

случае выбираем Wiggler;
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Рис. 4. Блок#схема связи хоста с целевой

системой через драйвер Macraigor

Рис. 5. Окно настройки драйвера Macraigor



● JTAG speed – скорость обмена хоста с

МК через отладочный интерфейс

JTAG. Задаваемое в этом поле значе�

ние должно лежать в диапазоне 1…8.

Чем больше это число, тем меньше

скорость. Как правило, кабель

Wiggler хорошо работает при ско�

рости, соответствующей 1, а для ка�

беля mpDemon может потребовать�

ся значение 2 или 3. В случае неус�

тойчивой связи хоста с МК скорость

обмена рекомендуется уменьшить.

Необходимо заметить, что прежде

чем использовать подключаемые че�

рез параллельный порт аппаратные

драйверы Macraigor (в частности,

Wiggler), необходимо установить на

компьютер хоста программные драй�

веры Macraigor или OCDemon (про�

грамма Macraigor JTAG drivers). Эти

драйверы входят в состав IDE IAR

Embedded Workbench и могут быть

установлены из начального инстал�

ляционного меню IDE. Окно на�

стройки CONNection Dialog установ�

ленной программы Macraigor JTAG

drivers показано на рис. 5. Параметры

подключенного интерфейсного уст�

ройства, заданные в этом окне (OCD
Interface Device (Wiggler), порт хоста

Connection (LPTn), скорость обмена

через JTAG OCD Speed), должны совпа�

дать с соответствующими параметра�

ми, заданными в опциях Debugger и

Macraigor C�SPY.

Перед началом отладки следует

убедиться, что на вывод P0.14 МК

LPC2000 целевой системы подан внеш�

ний низкий уровень, например, с по�

мощью перемычки. Кроме того, ли�

ния RTCK интерфейсного подключе�

ния JTAG целевой системы также

должна быть подключена к низкому

уровню (через резистор сопротивле�

нием 10 кОм).

Старт отладчика IAR C�SPY Debugger

производится с предварительно заг�

руженным в IAR EWARM пользова�

тельским приложением. Для старта

сеанса отладки следует выбрать

Project>Debug. Альтернативно можно

нажать кнопку Debugger в инструмен�

тальной панели. Следует заметить,

что для драйвера Macraigor типичной

является ситуация, когда хосту с пер�

вой попытки не удаётся установить

связь с целевой системой через JTAG,

о чём сигнализирует появление соот�

ветствующего сообщения. В этом слу�

чае придётся 1–2 раза «кликнуть» на

кнопке Повтор, чтобы инициировать

повторную попытку загрузки прог�

раммы в SRAM МК. Ход успешно на�

чавшегося процесса загрузки пользо�

вательской программы в SRAM отоб�

ражается графической шкалой. После

перехода в режим отладки в дополне�

ние к окнам, уже открытым в IAR

Embedded Workbench, пользователю

станет доступен набор специфичес�

ких окон IAR C�SPY Debugger (рис. 6).

При отладке в целевой системе, как

и при отладке в режиме симуляции,

команды отладчика Step Over и Step
Into позволяют выполнять пользова�

тельское приложение в пошаговом

режиме. Для выполнения программы

в SRAM в реальном времени следует

выбрать в меню Debug>Go. Именно в

таком темпе (или чуть медленнее)

программа будет выполняться в целе�

вой системе после её записи во Flash�

память МК.

Когда приложение выполняется,

кнопка Break на инструментальной

панели отладки подсвечивается крас�

ным цветом. Остановить выполнение

программы приложения можно,

«кликнув» на кнопке Break. Альтерна�

тивно следует выбрать в меню De
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bug>Break. Выход из C�SPY произво�

дится при выборе в меню Debug>Stop
Debugging. Альтернативно можно на�

жать кнопку Stop Debugging на инст�

рументальной панели. 

Мониторинг памяти (SRAM) и мони�

торинг регистров при отладке в целе�

вой системе внешне производится ана�

логично мониторингу SRAM и регист�

ров при отладке в режиме симулятора.

ЗАПИСЬ ПОЛЬЗОВАТЕЛЬСКИХ

ПРОГРАММ ВО FLASH@ПАМЯТЬ

LPC2000
Для создания законченного поль�

зовательского проекта отлаженную в

SRAM программу в итоге необходимо

записать во Flash�память МК. Для это�

го принципиально доступны два спо�

соба: программирование Flash�памя�

ти через встроенный интерфейс JTAG

средствами отладчика C�SPY (или от�

ладчиков других IDE) или програм�

мирование Flash�памяти через порт

UART0 средствами встроенного за�

грузчика bootloader LPC2000 (ISP�

программирование).

Записать программу во Flash�па�

мять через JTAG можно следующим

способом. Вместе с программой в

SRAM необходимо записать собствен�

ный промежуточный Flash�загрузчик,

который будет исполняться в SRAM и

организует запись самой программы

во Flash�память. Таким образом дейст�

вует, например, отладчик C�SPY, о чём

будет рассказано ниже.

Для облегчения возможности ISP�

программирования Flash�памяти

LPC2000 через UART0 средствами

bootloader производитель LPC2000

свободно распространяет компью�

терную программу LPC2000 Flash�

Utility, работающую под ОС Windows

Microsoft и использующую для прог�

раммирования Flash�памяти LPC2000

последовательный порт (COM) ком�

пьютера хоста. Описание возможнос�

тей LPC2000 Flash Utility будет приве�

дено ниже. Описание особенностей

режима ISP�программирования Flash�

памяти, реализованного в LPC2000

Flash Utility, а также алгоритмов рабо�

ты загрузчика приведено в [6].

В исходном тексте пользовательс�

кой программы, которую планирует�

ся загрузить во Flash�память и кото�

рая до этого загружалась в целях от�

ладки в SRAM, необходимо соответ�

ствующим образом скорректировать

константу инициализации специаль�

ного регистра MEMMAP, который

управляет переотображением в ад�

ресном пространстве памяти векто�

ров прерываний.

ЗАГРУЗКА FLASH@ПАМЯТИ

С ПОМОЩЬЮ LPC2000 FLASH

UTILITY

Код встроенного загрузчика Flash�

памяти bootloader выполняется при

каждом сбросе или включении пита�

ния МК, поскольку точка входа в

bootloader расположена по адресу

вектора сброса 0x0. В момент сброса

загрузчик производит выбор из двух

альтернативных возможностей: опре�

делить тактовую частоту устройства

и затем выполнять обработчик ко�

манд ISP�программирования или пе�

редать управление пользовательско�

му прикладному коду. Для запуска об�

работчика команд ISP�программиро�

вания должен быть сформирован со�

ответствующий внешний аппарат�

ный запрос. В качестве такого запро�

са выступает наличие внешнего низ�

кого уровня на выводе МК P0.14 во

время сброса. С целью исключения

возможности случайного входа в ре�

жим ISP�программирования LPC2000

необходимо предусмотреть на выво�

де P0.14 наличие внешнего подтяги�

вающего к «плюсу» питания резисто�

ра, поскольку после сброса этот вы�

вод находится в высокоимпенданс�

ном состоянии.

Программа LPC2000 Flash Utility

представляет собой графическую

оболочку для выполнения команд

ISP�программирования. Из своего

главного окна LPC2000 Flash Utility

позволяет производить с Flash�па�

мятью МК LPC2000 следующие опе�

рации: запись в Flash�память выбран�

ного файла с расширением hex – оп�

ция Upload to Flash, стирание Flash�

памяти – опция Erase, проверка

Flash�памяти на чистоту – опция

Blank Check, верификация Flash�па�

мяти – опция Compare Flash. Помимо

этого из главного окна может произ�

водиться чтение идентификацион�

ного номера (поле Part ID) устрой�

ства LPC2000 и номера версии встро�

енного загрузчика bootloader (поле

Boot Loader ID) с помощью опции

Read Device ID.

К недостаткам используемой авто�

ром версии LPC2000 Flash Utility мож�

но отнести только одно поддерживае�

мое расширение файлов «прошивки»

Flash�памяти – hex. Для того чтобы

сгенерировать выходной файл с рас�

ширением hex средствами IDE IAR

Embedded Workbench, следует вы�

брать в меню Project>Options, а затем в

категории Linker выбрать опию Allow
C
SPY
specific extra output file. На стра�

нице Extra Output следует выбрать оп�

цию Generate extra output file. В поле

Format этой страницы следует выб�

рать выходной формат intel
extended,

а в поле Format variant – None.

ЗАГРУЗКА FLASH@ПАМЯТИ

LPC2000 С ПОМОЩЬЮ

C@SPY
По умолчанию отладчик C�SPY заг�

ружает приложение в оперативную

память или во Flash�память устрой�

ства, когда запускается сеанс отладки.
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Рис. 6. Сеанс отладки в целевой системе



Однако опции Download отладчика

позволяют задать параметры такой

загрузки для достижения в итоге заг�

рузки во Flash. Flash�загрузчик может

быть описан как агент, который заг�

ружается в целевую систему. Он полу�

чает пользовательский код от отлад�

чика C�SPY и записывает его во Flash�

память. Flash�загрузчик использует

механизм файлового ввода�вывода,

чтобы читать прикладную програм�

му из хоста. Пользователь может выб�

рать один или несколько загрузчиков

Flash�памяти, каждый из которых заг�

рузит выбранную часть пользова�

тельского приложения. IDE IAR

Embedded Workbench поддерживает

набор загрузчиков Flash�памяти для

различных МК, в том числе для

LPC2000. Параметры загрузчика, не

входящего в этот набор, могут быть

заданы в IDE IAR Embedded

Workbench вручную.

Задание загрузчика Flash@памяти

Задание загрузчика Flash�памяти в

IDE IAR Embedded Workbench произ�

водится следующим образом:

1. Выбрать в меню Project>Options;

2. Выбрать в категории Debugger по�

зицию табуляции Download;

3. Выбрать поле Use Flash loader(s) и

«кликнуть» на кнопке Edit;
4. В открывшемся диалоговом окне

обзора загрузчиков Flash Loader
Overview будут перечислены все до�

ступные на текущий момент загруз�

чики Flash�памяти.

В случае необходимости пользова�

тель может добавить к списку загрузчи�

ков Flash�памяти новый загрузчик,

«кликнув» на кнопе New. При этом отк�

роется диалоговое окно конфигурации

загрузчика Flash Loader Configuration,

которое предоставляет возможность

конфигурировать загрузку. Если ранее

на странице General Options>Target был

произведён выбор устройства, у кото�

рого в IAR EWARM имеется встроенный

загрузчик Flash�памяти, то в окне Flash
Loader Overview по умолчанию будет

указан этот загрузчик.

С помощью кнопки OK выбранный

загрузчик(и) Flash�памяти может

быть задан для того, чтобы загрузить

приложение в Flash�память.

Кнопкой Delete можно удалить вы�

бранную конфигурацию загрузчика.

Механизм загрузки во Flash@память

Когда опция Use flash loader(s) вы�

брана и один или несколько загруз�

чиков Flash�памяти сконфигурирова�

ны, при запуске сеанса отладки будут

выполнены следующие шаги:

1. C�SPY загружает загрузчик Flash�

памяти в оперативную память це�

левой системы;

2. C�SPY начинает выполнение за�

грузчика Flash�памяти;

3. Загрузчик Flash�памяти открывает

файл, содержащий прикладной код;

4. Загрузчик Flash�памяти читает

прикладной код из файла и запи�

сывает его во Flash�память;

5. Выполнение загрузчика Flash�па�

мяти завершается;

6. C�SPY переключают контекст на

пользовательское приложение.

Шаги 1 – 5 выполняются для каждого

выбранного загрузчика Flash�памяти.

Требования к компоновке

Когда пользователь производит

формирование приложения, которое

будет загружено во Flash�память, не�

обходимо сгенерировать два выход�

ных файла с одинаковыми именами,

но разными расширениями, находя�

щихся по одному и тому же пути.

Первый из этих файлов обеспечива�

ет отладчик символьной и отладоч�

ной информацией и имеет формат

UBROF (расширение d79). Второй –

файл простого кода (расширение

sim), который будет открыт и прочи�

тан загрузчиком Flash�памяти, когда

последний будет загружать приложе�

ние во Flash�память МК.

Для задания установки создания

дополнительного выходной файла

следует выбрать в меню Pro

ject>Options, а затем в категории Lin

ker выбрать опию Allow C
SPY
specific
extra output file. На странице Extra
Output следует выбрать опцию Gene

rate extra output file. В поле Format
этой страницы следует выбрать вы�

ходной формат simple
code, а в поле

Format variant – None. В поле Output
file следует выбрать опцию Override
the default, тем самым не отменяя за�

данный по молчанию выходной

файл с расширением sim.

На странице Config категории Lin

ker необходимо задать командный

файл компоновщика, соответствую�

щий загрузке во Flash�память.

Порядок действий при загрузке

во Flash@память

Для записи кода во Flash�память

после компилирования и компонов�

ки проекта с описанными выше па�

раметрами необходимо перейти к

его отладке, выбрав в меню Pro

ject>Debug. Предварительно следует

убедиться, что на вывод P0.14 МК

LPC2000 подан внешний низкий

уровень. В случае успешной установ�

ки связи через JTAG после заверше�

ния процесса записи загрузчика в

SRAM, появится шкала, отображаю�

щая ход процесса загрузки во Flash�

память, и состоится переход в режим

отладки. Однако пользовательская

программа будет выполняться уже

во Flash�памяти МК, в чём можно

убедиться, отключив питание отла�

дочной платы и включив его снова

со снятой перемычкой, подающей

внешний низкий уровень на вывод

P0.14. Разъём кабеля JTAG на время

выполнения приложения во Flash�

памяти следует отключить от платы.

ЗАКЛЮЧЕНИЕ

Описание основных особенностей

IAR EWARM, приведённое выше, на�

глядно демонстрирует широкие воз�

можности этой профессиональной

отладочной среды. Как могли убе�

диться читатели, разработчик, ис�

пользуя только одну программную

оболочку, практически одновремен�

но создаёт и редактирует исходные

коды, отлаживает их в симуляторе

или в оперативной памяти МК целе�

вой системы, а по завершении отлад�

ки – записывает итоговый код в

«кристалл». При этом к его услугам

богатый набор «подручных» средств

и инструментов, облегчающих и

ускоряющих творческий процесс.
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