
В российской практике лишь несколь�

ко предприятий имеют налаженный

технологический процесс проектиро�

вания радиоэлектронной аппаратуры,

при котором обеспечивается связан�

ность на всех этапах проекта. Большин�

ство предприятий при разработке схем,

описания ПЛИС, плат, чертежей и текс�

товой конструкторской документации

используют различные программы.

Иногда схема разрабатывается в про�

грамме OrCAD, имеющей, по сложив�

шейся традиции, наиболее удобный ре�

дактор схем, а плата разрабатывается в

программе P�CAD 4.5, которая исполь�

зуется уже третий десяток лет.

При попытке реализовать сквозное

проектирование в системе Altium De�

signer пользователи сталкиваются с не�

обходимостью передачи ранее создан�

ных файлов схем, плат и библиотек в

новую среду, желая получить проект,

все документы которого имеют упомя�

нутую выше связанность. Рассмотрим

на примере процедуру согласования

такого проекта для файлов схемы и

платы, ранее созданных в P�CAD 2006,

хотя по аналогии можно выполнить
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Импорт проектов из различных САПР
ПП в программу Altium Designer

Сабунин Алексей (Москва)

В статье описана процедура импорта проектов из сторонних САПР
печатных плат в программу Altium Designer.

согласование документов, импортиро�

ванных из разных САПР.

В качестве примера воспользуемся

файлами DEMO1.SCH и DEMO2.PCB, ко�

торые можно скачать с интернет�стра�

ницы журнала (www.soel.ru). Эти файлы

были ранее сделаны в программе P�CAD

2006, причём файл платы получен пу�

тём загрузки списка соединений (Net�

list), сгенерированного по данной схе�

ме. В проекте отсутствуют библиотеки,

которые использовались при создании

схемы, что создаёт дополнительную

сложность для инженеров. Задача поль�

зователя в данной ситуации заключа�

ется в получении проекта, в котором

схема и плата будут взаимосвязаны друг

с другом, чтобы имелась возможность в

любой момент внести изменения из

схемы в плату и наоборот. Кроме этого,

в проекте должна быть библиотека со

всеми используемыми компонентами

для удобного внесения изменений в па�

раметры компонентов.

ПРОЦЕДУРА ИМПОРТА
Начнём процедуру импорта с соз�

дания новой рабочей группы коман�

дой File > New > Design Workspace. Дан�

ное действие не является обязатель�

ным, поскольку служит для объедине�

ния проектов и упрощения доступа к

ним. Сохраним рабочую группу ко�

мандой File > Save As Design Workspace

под названием DEMO. Теперь доступ к

документам проектов, входящих в

группу DEMO, обеспечивается выбо�

ром группы в выпадающем списке па�

нели Project.

Импорт из сторонних пакетов про�

ектирования рекомендуется начинать

командой File > Import Wizard, хотя

одиночные файлы схем, плат и библи�

отек можно импортировать командой

File > Open (в этом случае всё равно бу�

дет запущен мастер импорта (Import((

Wizard), но со второго шага). При вы�dd
боре мастера откроется список, в ко�

тором предлагается открыть проекты

следующих форматов:

● 99SE DDB Files – база данных проек�

та в формате Protel 99SE;

● Allegro Design Files – проект платы в

формате Allegro;

● DxDesigner – файлы схем и библио�

тек среды DxDesigner;

● CADSTAR Design and Libraries – про�

ект платы и библиотеки в формате

CADSTAR;

● CircuitMaker 2000 Schematics and Li�

braries Files – подсхемы и библиоте�

ки моделей среды моделирования

CircuitMaker 2000;

● OrCAD Design and Libraries – проект

платы и библиотеки в формате CAD�

STAR;

● PADS ASCII Design and Libraries Files –

проект платы и библиотеки в фор�

мате PADS ASCII;

● P�CAD Design and Libraries Files – про�

ект платы и библиотеки в формате

P�CAD ASCII.

После выбора строки P�CAD Design
and Libraries Files и нажатия кнопки

Next будет предложено указать файлы

схем и плат для импорта, где мы выби�

раем DEMO1.SCH и DEMO2.PCB. В следу�

ющем окне, очень похожем на преды�

дущее, будет предложено указать фай�

лы библиотек компонентов. В нашем

случае библиотеки отсутствуют, поэто�

© СТА�ПРЕСС

Рис. 1. Описание формата наименования посадочных мест компонентов схемы
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му пропускаем это окно нажатием

кнопки Next.tt
После недолгой процедуры анализа

будет показано следующее окно с на�

званием PCB Footprint Naming Format, вtt
котором предлагается указать формат

наименований посадочных мест. Дело

в том, в программах P�CAD 2006 и Al�

tium Designer отличается структура

библиотек, о чём говорилось выше (см.

СЭ № 6, 2008). В библиотеке P�CAD мо�

гут храниться объекты трёх типов: ком�

поненты, символы и посадочные места

(pattern). Каждый компонент может

иметь символ и/или посадочное мес�

то, которому соответствует несколько

графических изображений (pattern

graphics), использованных конструкто�

рами для реализации различных вари�

антов установки компонента.

В свою очередь, в библиотеке Altium

Designer могут храниться либо симво�

лы (SchLib), либо посадочные места

(PcbLib). При импорте из P�CAD компо�

нент в Altium Designer будет представ�

лен в виде символа, и у него будет лишь

одно посадочное место (Primary), а до�

полнительные посадочные места бу�

дут удалены. Таким образом, в текущем

окне программа предлагает указать,

как будет называться посадочное мес�

то (footprint) в Altium Designer. По

умолчанию в названии этого посадоч�

ного места будет присутствовать назва�

ние компонента, название pattern и

название pattern graphics. Учитывая,

что в дальнейшем придётся синхрони�

зировать проект, необходимо, чтобы

посадочные места назывались как Pat�

tern в P�CAD, для чего следует устано�

вить настройки, как показано на ри�

сунке 1. Следует отметить, что все раз�

делители между надписями в виде под�

черкиваний и скобок удалены.

После нажатия кнопки Next, в окнеtt

Reporting Options предполагается уста�

новка параметров вывода отчёта о на�

рушениях и предупреждениях, необ�

ходимость в котором отсутствует. Вы�

ключаем все параметры на данной

вкладке и переходим к следующему

шагу нажатием кнопки Next. В появив�tt
шемся окне Current Layer Mapping зада�

ётся соответствие слоёв P�CAD слоям

Altium Designer. Здесь следует внима�

тельно проверить и при необходимос�

ти переопределить графические слои,

т.к. данная информация в дальнейшем

попадёт на плату.

Например, по умолчанию слой гра�

фики для сборочного чертежа Top Assy
переносится на слой Mechanical Layer 1,

который многими разработчиками ис�

пользуется для контура платы, поэто�

му целесообразно в данной ситуации

задействовать отдельный слой (напри�

мер, Mechanical Layer 5). Вообще работа

с графическими слоями должна быть

заранее продумана и регламентирова�

на внутри предприятия [1], чтобы гра�

фическая информация, используемая

для различных задач, не попадала на

один слой. Пример распределения гра�

фических слоёв программы Altium (Me�((

chanical Layer) показан в таблице 1.rr
На следующем шаге, в окне Outputs

PCB Project показана структура проек�

тов, которые будут созданы при им�

порте указанных файлов. По умолча�

нию для каждого файла будет создан

отдельный проект платы. В нашем слу�

чае схема и плата относятся к одному

проекту, поэтому целесообразно их

объединить уже на этапе импорта. Для

этого переместим файлы из проекта

DEMO2 в проект DEMO1 и присвоим

проекту название DEMO (см. рис. 2).

Это был последний шаг настроек им�

порта, поэтому нажатие кнопки Next
приводит к процедуре трансляции,

после чего появляется окно с активной

кнопкой. Результатом импорта файлов

схемы и платы является запуск панели

Project, в которой показана структураtt
нового проекта (см. рис. 3). В проекте,

помимо файла схемы и платы, имеют�

ся файлы с расширением *.OUTJOB и

*.LOG.. ; первый представляет собой файл

настроек вывода документации, вто�

рой – отчёт об импорте. Файл *.LOG
вряд ли будет использоваться, а файл

*.OUTJOB пригодится в дальнейшем.

Таблица 1. Назначение механических слоёв

Имя слоя Номер слоя Назначение

Board Mechanical 1 Границы конструктива

Plata Mechanical 2 Информация, идущая на чертёж платы (сборочный). Форматка, таблица отверстий,
технические требования, размеры, порядок сборки слоёв

Top 3D Body Mechanical 3 Проекция трёхмерных деталей на плате для верхнего слоя

Bot 3D Body Mechanical 4 Проекция трёхмерных деталей на плате для нижнего слоя

Top Assy Mechanical 5 Информация, идущая на сборочный чертёж (верх). Графика корпусов и т.п.
на верхней стороне, форматка, установка компонентов

Bot Assy Mechanical 6 Информация, идущая на сборочный чертёж (низ). Графика корпусов и т.п.
на нижней стороне, форматка

Grid Mechanical 7 Оцифровка для платы (прямая)

Grid Mirror Mechanical 8 Оцифровка для платы (зеркальная)

Top Dimension Mechanical 9 Размерные линии для сборочного чертежа (верхняя сторона)

Bot Dimension Mechanical 10 Размерные линии для сборочного чертежа (нижняя сторона)

Template Mechanical 11 Форматка по ГОСТ для послойных чертежей платы

Template Mirror Mechanical 12 Зеркальная форматка по ГОСТ для послойных чертежей платы

– Mechanical 13–16 Дополнительные слои

Рис. 2. Последний этап импорта – определение структуры проекта



ВЕРИФИКАЦИЯ СХЕМЫ
После импорта необходимо синхро�

низировать проект, но прежде чем это

сделать, надо убедиться в корректнос�

ти импорта схемы. При передаче схе�

мы из P�CAD могут появиться следую�

щие «неприятности»: лишние метки

цепей (1), точки у текстовых надписей

(2) и обрывы портов питания (3), как

показано на рисунке 4.

Исправить первые два пункта мож�

но с помощью глобального редакти�

рования, о котором было подробно

рассказано в статье СЭ № 4, 2009. В

нашем случае метки цепей необхо�

димо удалить, для чего их следует вы�

делить нажатием ПКМ на любой мет�

ке цепи и выбором команды Find
Similar Object (параметры запроса

показаны на рисунке 5). В главной

строке запроса Text указано значе�

ния NET*, по результатам которогоTT
будут выбраны все метки, имеющие

неопределённое название, а также

начинающиеся с букв NET. После вы�TT

деления удаляем метки нажатием

кнопки Del.

Чтобы убрать точки в текстовых над�

писях, придётся выполнить немного

больше действий. Нажимаем ПКМ на

любом компоненте и выбираем коман�

ду Find Similar Object, после чего сразуtt
нажимаем кнопку ОК. Этим действиемКК

были выбраны все компоненты схемы

и запущена панель Inspector. В панелиrr
Inspector показаны свойства компонен�

та; некоторые из них представлены в

виде гиперссылок (Component Designa�

tor, rr Part Comment, tt Value). Выбором, на�

пример, строки Component Designator
будет выполнен переход к свойствам

позиционных обозначений всех ком�

понентов.

В нашем случае необходимо в свой�

ствах позиционных обозначений в

строке Orientation ввести значение 0

(т.к. некоторые надписи были перевер�

нуты в P�CAD) и включить параметр

Autoposition, тогда на схеме не будет

отображаться точка привязки текста.

После установки параметров для Com�
ponent Designator находим среди пара�

метров строку Owner, которая возвра�rr
щает режим работы со свойствами

компонентов. Аналогично редактиру�

ем настройки для остальных текстов

(Part Comment(( и Value).

После выполнения вышеперечис�

ленных процедур схема принимает

удобочитаемый вид, однако необходи�

мо провести компиляцию, которая вы�

явит дополнительные недочёты. Про�

цедура компиляции была подробно

описана в статье СЭ № 7, 2008. В дан�

ном случае для проверки важно вклю�

чить настройки Net with only one pin
(цепь, подключенная только к одному

выводу) и Floating Power objects (непод�

ключенный порт питания) в режим Fa�
tal Error на вкладке Project > Project Op�

tions (Error Reporting). В результате ком�

пиляции (Project > Compile Project(( )tt
программа выявит группу нарушений,

связанных с тем, что порты питания

не подключены к цепям. Данную

ошибку можно исправить только вруч�

ную. Для дальнейшей работы необхо�

димо добиться того, чтобы при компи�

ляции программа не выдавала сообще�

ний об ошибках. После успешной

компиляции можно переходить к

синхронизации схемы и платы.

СИНХРОНИЗАЦИЯ ПРОЕКТА
Если открыть схему Sheet1.SCHDOC

из проекта DEMO.PRJPCB и выделить

на ней компонент D1, то этот же ком�

понент будет выделен и на плате

DEMO2.PCBDOC, т.е. можно говорить о

том, что программа «понимает» связан�

ность между символом на схеме и по�

садочным местом на плате. Но в

действительности это не совсем так.

Убедиться в этом можно, зайдя в свой�

ства компонента на схеме и сравнив

их со свойствами компонента на плате.

Для нашего проекта свойства компо�

нента D1 на схеме и плате отличаются

(интересующие нас параметры пока�

заны в таблице 2).

Анализируя данные, приведённые в

таблице 2, можно утверждать, что:

● не совпадают уникальные номера

(Unique Id), по которым программаdd
синхронизирует компонент на схе�

ме и плате;

● не совпадают названия контактных

площадок, причём в плате название

контактной площадки имеет некор�

ректное название;

● не указана библиотека, из которой

взяты компоненты, что не позволит

внести изменения из схемы в плату.

Соответственно, для синхронизации

проекта необходимо исправить все
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Рис. 3. Структура импортированного проекта

Рис. 5. Запрос для поиска всех меток цепей,

начинающихся с NET

Рис. 4. Фрагмент импортированной схемы
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три недочёта. Для начала необходимо

пояснить поле Library name. Если име�

ется библиотека, то следует в схеме

указать ссылку на неё для каждого ком�

понента. В нашем случае такой библи�

отеки нет, поэтому рассмотрим, как её

восстановить по имеющимся данным.

Находясь в схеме, создадим библио�

теку используемых в проекте компо�

нентов командой Design > Make Sche�
matic Library и сохраним созданную

библиотеку командой File > Save под

текущим названием DEMO.SCHLIB.

Следует обратить внимание, что у всех

компонентов библиотеки имеется

ссылка на посадочное место, но самих

посадочных мест пока нет. Теперь ана�

логичным образом из платы создадим

библиотеку используемых посадоч�

ных мест командой Design > Make PCB
Library и сохраним её командой File >
Save под названием DEMO2.PCBLIB. Всё

было бы хорошо, если бы наименова�

ния посадочных мест в этих двух биб�

лиотеках совпадали, но в последней

библиотеке к именам добавлен знак

нижнего подчеркивания. Исправить

ситуацию можно переименованием

всех посадочных мест в библиотеке

DEMO2.PCBLIB (в названиях необходи�

мо удалить последний символ).

Итак, у нас имеется библиотека сим�

волов, в которой все компоненты име�

ют посадочные места. (Убедитесь, что

обе библиотеки входят в структуру

проекта DEMO.PRJPCB! Если одна из

библиотек не находится в проекте, то

её необходимо переместить в проект.)

Теперь следует для всех компонентов

схемы задать ссылку на библиотеку, в

которой содержатся требуемые ком�

поненты. Для этого в схеме нажимаем

ПКМ на любом компоненте и выбира�

ем команду Find Similar Object, после

чего нажимаем ОК. В появившейся па�КК
нели Inspector убеждаемся, что выбра�

ны все компоненты схемы – в строке

состояния панели будет написано «47
object are displayed in 1 document». Далееtt
находим в панели Inspector строку

Library и вносим туда название

DEMO.SCHLIB.

Теперь можно выполнить согласова�

ние схемы с платой, для чего, находясь

в схеме, выполним команду Design >
Update PCB Document (предваритель�

но все документы, используемые в про�

екте, должны быть сохранены). По�

явившееся окно Failed to match 41… го�

ворит о том, что у компонента 41 не

совпадают уникальные номера на схе�

ме и плате и программа предлагает со�

поставить компоненты автоматичес�

ки по позиционным обозначениям. В

нашем случае данный вариант очеви�

ден, поэтому нажимаем кнопку Yes. Да�

лее появляется окно Engineering Change
Order (перечень изменений), знакомое

пользователям P�CAD в виде файла

*.ECO.. . Здесь представлен структуриро�

ванный список изменений, которые

предлагается внести из схемы в плату.

Основная часть изменений понятна –

изменяются ссылки на посадочные

места и названия цепей, а в конце

предлагается удалить классы цепей, до�

бавить классы компонентов и комнаты

(см. рисунок 6)

Другими словами, программа пред�

лагает внести изменения, которые не

требуются для дальнейшей работы.

(Работа с классами компонентов и

комнатами на данной плате не акту�

альна, а созданные ранее в плате клас�

сы цепей POWER и DIFF_PAIR не требу�

ется удалять.) Поэтому необходимо

установить настройки списка парамет�

ров, которые будут проверяться при

синхронизации схемы с платой. Отка�

жемся от дальнейшей синхронизации,

закрыв окно Engineering Change Order,rr

и перейдём к настройкам проекта Pro�
ject > Project Options (Comparator). В

открытой вкладке представлен список

тех элементов, по которым программа

предлагает вносить изменения из схе�

мы в плату. Здесь надо исключить из

проверки следующие пункты:

● Extra Room Definition – Изменять

настройки комнат;

● Extra Net Classes – Изменять настрой�

ки классов цепей;

● Extra Component Classes – Изменять

настройки классов компонентов.

Чтобы исключить перечисленные

пункты из проверки, необходимо в

столбце Mode для этих пунктов вы�

брать вариант Ignore Differences. Теперь

выполним синхронизацию, повторив

из схемы команду Design > Update. Для

завершения внесения изменений в

плату необходимо в окне Engineering
Change Order последовательно нажать

кнопки Validate Changes и Execute
Changes. При этом если после нажатия

кнопки Validate Changes напротив од�

ного из компонентов появится крас�

ный крест в столбце Check, необходи�

мо проверить посадочное место дан�

ного компонента. В нашем случае

синхронизация должна быть выпол�

нена без предупреждений, если были

внимательно проделаны все действия,

рекомендованные выше.

Теперь мы имеем проект, в котором

схема полностью соответствует плате,

но у компонентов не совпадают уни�

кальные номера (Unique Id), о которыхdd
шла речь в таблице 2. Возникает вопрос:

чем это может грозить для целостности

проекта в дальнейшем? Для демонстра�

ции необходимости совпадения уни�

кальных номеров у компонентов на

схеме и платы изменим позиционное

обозначение компонента D1 на D133 в

схеме. Теперь из редактора схем попро�

буем повторно внести изменения из

схемы в плату (Design > Update PCB Doc�((

ument). При этом появится окно t Failed to
match 39…, говорящее о несовпадении

уникальных номеров компонентов, и,

после нажатия кнопки Yes, появится ок�

но Match Nets. Последнее окно предлага�

ет вручную назначить цепи, имена ко�

торых не совпадают в схеме и плате, что

не всегда удобно делать. В данном слу�

чае нажимаем кнопку Continue, чтобы

пропустить ручное назначение, а в

Таблица 2. Параметры компонента D2 на схеме и плате

Рис. 6. Перечень изменений (ECO)

Наименование параметра Значение на схеме Значение на плате

Library name * Нет значения

Footprint 401.1421 401.1421_

Unique Id DJMSKMXL Нет значения



дальнейшем отключим такую возмож�

ность в настройках (*). После заверше�

ния синхронизации на плате будет уда�

лён компонент D1 и добавлен в свобод�

ное поле компонент D133. При этом

сам компонент и его связи не измени�

лись, а было изменено лишь обозначе�

ние компонента.

Теперь в плате выполним «откат»

последних действий командой Edit >

Undo (Ctrl+Z) и посмотрим, что прои�

зойдёт, если у компонентов схемы и

платы будут одинаковые уникальные

номера. Находясь в редакторе плат, вы�

полним команду Project > Component

Links, в результате чего на экране поя�

вится окно, показанное на рисунке 7.

Здесь в левом списке перечислены

компоненты схемы, у которых нет со�

ответствующих (по уникальному но�

меру модели) компонентов на плате. В

центральном списке – модели компо�

нентов на плате, которые отсутствуют

в схеме. В правом списке показаны

компоненты, согласованные в схеме и

плате. В нашем случае таких компо�

нентов нет.

Согласование можно проводить

вручную или автоматически, кноп�

кой Add Pairs Matched By, по одному

из критериев: Designator (позицион�

ное обозначение), Comment (назва�

ние компонента), Footprint (посадоч�

ное место) или по нескольким из

них. В данном случае автоматически

назначим пары по позиционному

обозначению, для чего следует на�

жать Add Pairs Matched By при вклю�

ченном параметре Designator и вы�

ключенных настройках Comment и

Footprint. (Если элемент D133 не был

обратно переименован в D1, то в дан�

ном окне назначим вручную соответс�

твие D133 в схеме и D1 на плате.) За�

канчиваем процедуру нажатием

кнопки Perform Update, в результате

чего будет выведено сообщение об

обновлении 39 ссылок.

Теперь зададим настройку (*), позво�

ляющую не предлагать диалог ручного

согласования имен цепей, классов и т.д.

Для этого открываем настройки про�

екта Project > Project Options (Compara�
tor) и в нижней части окна запрещаем

показывать диалог ручного назначе�

ния соответствия цепей (см. рис. 8).

Теперь при изменении позицион�

ных обозначений в схеме и попытке

синхронизации проекта (Design Update((

PCB Document) программа лишь изме�t

нит позиционное обозначение компо�

нентов на плате и автоматически из�

менит названия цепей, идущих от это�

го компонента.

Описанный подход к созданию со�

гласованного проекта из импортиро�

ванных схемы и платы в формате P�

CAD может иметь несколько вариан�

тов. В целом рассмотренные приёмы

могут быть использованы и при им�

порте схемы и платы из двух различ�

ных САПР ПП.
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Рис. 7. Согласование уникальных номеров компонентов схемы и платы

Рис. 8. Отключение диалога ручной установки соответствия названий цепей
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